aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-07-06 17:11:00 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-07-12 12:06:01 +0200
commitfc7eda558f058317789680d13149af63d86e372d (patch)
tree8e3743b766620a548f1d2dd3725684d3008cbfe1
parent1295dedccd2744970cea8dba7157432323936f3b (diff)
downloadmeta-openembedded-fc7eda558f058317789680d13149af63d86e372d.tar.gz
llvm: use newer class-native overrides instead of virtclass
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-core/llvm/llvm-common.bb2
-rw-r--r--meta-oe/recipes-core/llvm/llvm2.inc10
2 files changed, 6 insertions, 6 deletions
diff --git a/meta-oe/recipes-core/llvm/llvm-common.bb b/meta-oe/recipes-core/llvm/llvm-common.bb
index 192919ee92..395ab01518 100644
--- a/meta-oe/recipes-core/llvm/llvm-common.bb
+++ b/meta-oe/recipes-core/llvm/llvm-common.bb
@@ -14,7 +14,7 @@ llvm_common_sysroot_preprocess() {
install -m 0755 ${WORKDIR}/llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
}
-do_install_virtclass-native() {
+do_install_class-native() {
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
}
diff --git a/meta-oe/recipes-core/llvm/llvm2.inc b/meta-oe/recipes-core/llvm/llvm2.inc
index 5ae993afd1..b239d30f44 100644
--- a/meta-oe/recipes-core/llvm/llvm2.inc
+++ b/meta-oe/recipes-core/llvm/llvm2.inc
@@ -1,5 +1,5 @@
DEPENDS = "llvm${LLVM_RELEASE}-native llvm-common"
-DEPENDS_virtclass-native = "llvm-common-native cmake-native"
+DEPENDS_class-native = "llvm-common-native cmake-native"
SRC_URI = "http://llvm.org/releases/${PV}/llvm-${PV}.tgz"
S = "${WORKDIR}/llvm-${PV}"
@@ -57,7 +57,7 @@ PACKAGES_DYNAMIC = "llvm-*"
# the difference to the non-native build is that we do not need
# to declare the location of the tblgen executable.
-EXTRA_OECMAKE_virtclass-native = "\
+EXTRA_OECMAKE_class-native = "\
-DLLVM_TARGETS_TO_BUILD=${LLVM_ARCH} \
-DCMAKE_LINKER:FILEPATH=${LD} \
-DCMAKE_AR:FILEPATH=${AR} \
@@ -68,9 +68,9 @@ EXTRA_OECMAKE_virtclass-native = "\
-DNM_PATH:FILEPATH=${NM} \
"
-PACKAGES_virtclass-native = ""
+PACKAGES_class-native = ""
-PACKAGES_DYNAMIC_virtclass-native = ""
+PACKAGES_DYNAMIC_class-native = ""
python populate_packages_prepend () {
libllvm_libdir = bb.data.expand('${libdir}/${LLVM_DIR}', d)
@@ -130,7 +130,7 @@ llvm_sysroot_preprocess() {
install -m 0755 bin/llvm-config${LLVM_RELEASE} ${SYSROOT_DESTDIR}${bindir_crossscripts}
}
-do_install_virtclass-native() {
+do_install_class-native() {
# Install into a private directory to be able to reorganize the files.
cd ${LLVM_BUILD_DIR}
oe_runmake DESTDIR=${LLVM_INSTALL_DIR} install