aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-07-13 09:12:09 +0000
committerEric Bénard <eric@eukrea.com>2012-07-13 11:28:29 +0200
commit182fa461447cdfcf3c384b7c1627d8fe8b9c94c0 (patch)
tree2d4302e3b01cafb736e21d29074ae6224d84ee99
parent2a5b460500192b1be6f44d1283cc96aac8377d18 (diff)
downloadmeta-openembedded-182fa461447cdfcf3c384b7c1627d8fe8b9c94c0.tar.gz
opencv, opencv-samples: drop 2.3.1
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--meta-oe/recipes-support/opencv/opencv-samples_2.3.bb42
-rw-r--r--meta-oe/recipes-support/opencv/opencv/0001-Fix-CMakeLists.txt-numpy-detection.patch37
-rw-r--r--meta-oe/recipes-support/opencv/opencv_2.3.bb76
3 files changed, 0 insertions, 155 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv-samples_2.3.bb b/meta-oe/recipes-support/opencv/opencv-samples_2.3.bb
deleted file mode 100644
index 89bbc01db6..0000000000
--- a/meta-oe/recipes-support/opencv/opencv-samples_2.3.bb
+++ /dev/null
@@ -1,42 +0,0 @@
-DESCRIPTION = "Opencv : The Open Computer Vision Library"
-HOMEPAGE = "http://opencv.willowgarage.com/wiki/"
-SECTION = "libs"
-LICENSE = "BSD"
-
-DEPENDS = "opencv"
-
-LIC_FILES_CHKSUM = "file://include/opencv2/opencv.hpp;endline=41;md5=6d690d8488a6fca7a2c192932466bb14 \
-"
-
-SRC_URI = "svn://code.ros.org/svn/opencv/tags/2.3.1;module=opencv;proto=https \
-"
-
-SRCREV = "7198"
-PV = "2.3.1"
-PR = "r2"
-
-S = "${WORKDIR}/opencv"
-
-do_install() {
- cd samples/c
- install -d ${D}/${bindir}
- install -d ${D}/${datadir}/opencv/samples
-
- cp * ${D}/${datadir}/opencv/samples || true
-
- for i in *.c; do
- echo "compiling $i"
- ${CXX} ${CFLAGS} ${LDFLAGS} -ggdb `pkg-config --cflags opencv` -o `basename $i .c` $i `pkg-config --libs opencv` || true
- install -m 0755 `basename $i .c` ${D}/${bindir} || true
- rm ${D}/${datadir}/opencv/samples/`basename $i .c` || true
- done
- for i in *.cpp; do
- echo "compiling $i"
- ${CXX} ${CFLAGS} ${LDFLAGS} -ggdb `pkg-config --cflags opencv` -o `basename $i .cpp` $i `pkg-config --libs opencv` || true
- install -m 0755 `basename $i .cpp` ${D}/${bindir} || true
- rm ${D}/${datadir}/opencv/samples/`basename $i .cpp` || true
- done
-}
-
-FILES_${PN}-dev += "${datadir}/opencv/samples/*.c* ${datadir}/opencv/samples/*.vcp* ${datadir}/opencv/samples/build*"
-FILES_${PN} += "${bindir} ${datadir}/opencv"
diff --git a/meta-oe/recipes-support/opencv/opencv/0001-Fix-CMakeLists.txt-numpy-detection.patch b/meta-oe/recipes-support/opencv/opencv/0001-Fix-CMakeLists.txt-numpy-detection.patch
deleted file mode 100644
index dba00f8a1d..0000000000
--- a/meta-oe/recipes-support/opencv/opencv/0001-Fix-CMakeLists.txt-numpy-detection.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From a7301911a3cdf9196abd93ff894a9e86e0bcdc5e Mon Sep 17 00:00:00 2001
-From: Connor Abbott <cwabbott0@gmail.com>
-Date: Sun, 30 Oct 2011 20:00:03 -0400
-Subject: [PATCH] Fix CMakeLists.txt numpy detection
-
-Right now, the code opencv uses to detect where the numpy include files are doesn't work with cross-compiling because it uses the native python to determine the environment. To make this a little better, allow the user to explictly specify the path using -DPYTHON_NUMPY_INCLUDE_DIRS=path/to/numpy/include/dir .
-Signed-off-by: Connor Abbott <cwabbott0@gmail.com>
----
- CMakeLists.txt | 12 ++++++++----
- 1 files changed, 8 insertions(+), 4 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ff8f20c..8edbd78 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -715,10 +715,14 @@ IF ("${PYTHON_VERSION_MAJOR_MINOR}" VERSION_GREATER 2.4)
- ENDIF()
-
- # Attempt to discover the NumPy include directory. If this succeeds, then build python API with NumPy
--execute_process(COMMAND ${PYTHON_EXECUTABLE} -c "import os; os.environ['DISTUTILS_USE_SDK']='1'; import numpy.distutils; print numpy.distutils.misc_util.get_numpy_include_dirs()[0]"
-- RESULT_VARIABLE PYTHON_NUMPY_PROCESS
-- OUTPUT_VARIABLE PYTHON_NUMPY_INCLUDE_DIRS
-- OUTPUT_STRIP_TRAILING_WHITESPACE)
-+if(NOT DEFINED PYTHON_NUMPY_INCLUDE_DIRS)
-+ execute_process(COMMAND ${PYTHON_EXECUTABLE} -c "import os; os.environ['DISTUTILS_USE_SDK']='1'; import numpy.distutils; print numpy.distutils.misc_util.get_numpy_include_dirs()[0]"
-+ RESULT_VARIABLE PYTHON_NUMPY_PROCESS
-+ OUTPUT_VARIABLE PYTHON_NUMPY_INCLUDE_DIRS
-+ OUTPUT_STRIP_TRAILING_WHITESPACE)
-+else()
-+ set(PYTHON_NUMPY_PROCESS 0)
-+endif()
-
- if(PYTHON_NUMPY_PROCESS EQUAL 0)
- set(PYTHON_USE_NUMPY 1)
---
-1.7.4.1
-
diff --git a/meta-oe/recipes-support/opencv/opencv_2.3.bb b/meta-oe/recipes-support/opencv/opencv_2.3.bb
deleted file mode 100644
index 0534c27918..0000000000
--- a/meta-oe/recipes-support/opencv/opencv_2.3.bb
+++ /dev/null
@@ -1,76 +0,0 @@
-DESCRIPTION = "Opencv : The Open Computer Vision Library"
-HOMEPAGE = "http://opencv.willowgarage.com/wiki/"
-SECTION = "libs"
-
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://include/opencv2/opencv.hpp;endline=41;md5=6d690d8488a6fca7a2c192932466bb14"
-
-ARM_INSTRUCTION_SET = "arm"
-
-DEPENDS = "python-numpy gstreamer gtk+ libtool swig swig-native python jpeg bzip2 zlib libpng tiff glib-2.0"
-
-SRC_URI = "svn://code.ros.org/svn/opencv/tags/2.3.1;module=opencv;proto=https \
- file://opencv/0001-Fix-CMakeLists.txt-numpy-detection.patch \
- "
-
-SRCREV = "7198"
-
-PV = "2.3.1"
-PR = "r3"
-
-S = "${WORKDIR}/opencv"
-
-EXTRA_OECMAKE = "-DPYTHON_NUMPY_INCLUDE_DIRS=${STAGING_LIBDIR}/${PYTHON_DIR}/site-packages/numpy/core/include \
- -DBUILD_PYTHON_SUPPORT=ON \
- -DWITH_FFMPEG=OFF \
- -DWITH_GSTREAMER=ON \
- "
-
-inherit distutils-base pkgconfig cmake
-
-export BUILD_SYS
-export HOST_SYS
-export PYTHON_CSPEC="-I${STAGING_INCDIR}/${PYTHON_DIR}"
-export PYTHON="${STAGING_BINDIR_NATIVE}/python"
-
-TARGET_CC_ARCH += "-I${S}/include "
-
-PACKAGES += "${PN}-apps python-opencv"
-
-python populate_packages_prepend () {
- cv_libdir = bb.data.expand('${libdir}', d)
- cv_libdir_dbg = bb.data.expand('${libdir}/.debug', d)
- do_split_packages(d, cv_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev', allow_links=True)
- do_split_packages(d, cv_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev')
- do_split_packages(d, cv_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev')
- do_split_packages(d, cv_libdir, '^lib(.*)\.so\.*', 'lib%s', 'OpenCV %s library', extra_depends='', allow_links=True)
-
- pn = bb.data.getVar('PN', d, 1)
- metapkg = pn + '-dev'
- bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d)
- blacklist = [ metapkg ]
- metapkg_rdepends = [ ]
- packages = bb.data.getVar('PACKAGES', d, 1).split()
- for pkg in packages[1:]:
- if not pkg in blacklist and not pkg in metapkg_rdepends and pkg.endswith('-dev'):
- metapkg_rdepends.append(pkg)
- bb.data.setVar('RRECOMMENDS_' + metapkg, ' '.join(metapkg_rdepends), d)
-}
-
-FILES_${PN} = ""
-FILES_${PN}-apps = "${bindir}/* ${datadir}/OpenCV"
-FILES_${PN}-dbg += "${libdir}/.debug"
-FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig"
-FILES_${PN}-doc = "${datadir}/OpenCV/doc"
-
-ALLOW_EMPTY_${PN} = "1"
-
-INSANE_SKIP_python-opencv = "True"
-DESCRIPTION_python-opencv = "Python bindings to opencv"
-FILES_python-opencv = "${PYTHON_SITEPACKAGES_DIR}/*"
-RDEPENDS_python-opencv = "python-core python-numpy"
-
-do_install_append() {
- cp ${S}/include/opencv/*.h ${D}${includedir}/opencv/
- sed -i '/blobtrack/d' ${D}${includedir}/opencv/cvaux.h
-}