aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Agner <stefan@agner.ch>2015-05-20 08:52:08 +0200
committerArmin Kuster <akuster808@gmail.com>2015-05-31 07:03:50 -0700
commite00844ed8cb964857c73acd8495ae98250c9020f (patch)
tree55abaa7394404da07e11128c6eb356458129b6cb
parent5b6f39ce325d490fc382d5d59c5b8b9d5fa38b38 (diff)
downloadmeta-openembedded-e00844ed8cb964857c73acd8495ae98250c9020f.tar.gz
ptpd: disable libpcap detection via pcap-config
When the host system provides pcap-config, the configure scripts detect that and add a bogous CPPFLAG: checking for pcap-config... /usr/bin/pcap-config checking if we want to build with libpcap support... yes, pcap-config ... PCAP_CPPFLAGS = -I/usr/include Which down the line can lead to compile errors due to wrong headers being included. Fix this issue by using --with-pcap-config=no which prevents detection using pcap-config but does "guessing", which works fine for OE. Signed-off-by: Stefan Agner <stefan@agner.ch> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-daemons/ptpd/ptpd_2.3.1-rc2.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1-rc2.bb b/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1-rc2.bb
index db74e44631..b6abfeef86 100644
--- a/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1-rc2.bb
+++ b/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1-rc2.bb
@@ -8,7 +8,7 @@ SECTION = "network"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://README;md5=2452033fe374283f29579898663b1aa8"
-DEPENDS = "libpcap"
+DEPENDS = "linux-libc-headers libpcap"
inherit autotools
@@ -30,7 +30,7 @@ S = "${WORKDIR}/ptpd-${PV}"
EXTRA_OEMAKE = ""
-EXTRA_OECONF += "--disable-snmp"
+EXTRA_OECONF += "--disable-snmp --with-pcap-config=no"
do_install() {
install -d ${D}${bindir} ${D}${mandir}/man8