aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-11-26 00:42:03 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2015-01-28 08:59:25 +0100
commit44c2fd2b393408ae22701071006918b1ea01f3d5 (patch)
tree67db0dbcf130ce354e6de6b24f8883b0b45ff06c
parent9e3eab116ac01b451a5ce681d6643b155e552520 (diff)
downloadmeta-openembedded-44c2fd2b393408ae22701071006918b1ea01f3d5.tar.gz
meta-python: Add LAYERVERSION and LAYERDEPENDS
According to README, it depends on oe-core and openembedded-layer Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/conf/layer.conf6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-python/conf/layer.conf b/meta-python/conf/layer.conf
index 4e8eca3c33..55169e4fbb 100644
--- a/meta-python/conf/layer.conf
+++ b/meta-python/conf/layer.conf
@@ -7,3 +7,9 @@ BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
BBFILE_COLLECTIONS += "meta-python"
BBFILE_PATTERN_meta-python := "^${LAYERDIR}/"
BBFILE_PRIORITY_meta-python = "7"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_meta-python = "1"
+
+LAYERDEPENDS_meta-python = "core openembedded-layer"