aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-11-30 16:08:01 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2013-11-30 16:46:51 +0100
commitf96d27193fa6f35035e2487b5bdeebec84ccec50 (patch)
tree99572e8e057c41b9e9e8ee04c4a12b7ce925abda
parent191499a2b54d04855284347ce5a067f998646be4 (diff)
downloadmeta-openembedded-f96d27193fa6f35035e2487b5bdeebec84ccec50.tar.gz
xserver-common: Rename Xsession.d files to end with .sh extension
* oe-core version of xinput-calibrator installs 30xinput_calibrate.sh and ls -X used in Xsession script sorts it as last (not respecting the numbers) and xinput-calibrator is executed too late (after 90xXWindowManager) * don't forget to update all your components installing Xsession.d files as well Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb b/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
index 481e438994..5bc37b03f4 100644
--- a/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
+++ b/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
@@ -28,6 +28,13 @@ SRC_URI_append = " \
do_install_append() {
sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common
+ # Rename all Xsession files not ending with .sh
+ # Unfortunatelly when xinput-calibrator was moved to oe-core
+ # its Xsession file got name 30xinput_calibrate.sh and ls -X sorts it
+ # last, not respecting numbers for sorting them
+ for i in ${D}/${sysconfdir}/X11/Xsession.d/*; do
+ echo $i | grep '.sh$' || mv $i $i.sh
+ done
}
inherit allarch