aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2020-07-02 16:52:16 +0800
committerArmin Kuster <akuster808@gmail.com>2020-07-12 19:20:37 -0700
commit1f77d18cc63f82b51ca5df1b1fefd870b3fd5d1c (patch)
tree4ef4f94d179fb8a4113f669c44fd24eb83b525bc
parentaa6371f7bf24ae3fa3da7974f953502995b79c8f (diff)
downloadmeta-openembedded-1f77d18cc63f82b51ca5df1b1fefd870b3fd5d1c.tar.gz
paho-mqtt-c: Fix build error when enable multilib.
The error is as the following: ERROR: paho-mqtt-c-1.3.2-r0 do_package: QA Issue: paho-mqtt-c: Files/directories were installed but not shipped in any package: /usr/lib /usr/lib/cmake /usr/lib/cmake/eclipse-paho-mqtt-c /usr/lib/cmake/eclipse-paho-mqtt-c/eclipse-paho-mqtt-cConfig.cmake /usr/lib/cmake/eclipse-paho-mqtt-c/eclipse-paho-mqtt-cConfigVersion.cmake /usr/lib/cmake/eclipse-paho-mqtt-c/eclipse-paho-mqtt-cConfig-noconfig.cmake Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 93aa8defe3fae48c48b364136a0af8a58fd2be95) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.3.2.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.3.2.bb b/meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.3.2.bb
index 071d51fc60..3a1222e89e 100644
--- a/meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.3.2.bb
+++ b/meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.3.2.bb
@@ -22,6 +22,10 @@ S = "${WORKDIR}/git"
inherit cmake
+do_configure_prepend() {
+ sed -i s:\ lib/cmake:\ ${baselib}/cmake:g ${S}/src/CMakeLists.txt
+}
+
do_install_append() {
# paho-mqtt installes some thing that we don't want.
rm -rf ${D}${prefix}/samples