aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-10-24 08:39:12 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-24 08:39:12 +0200
commit80ef3c0aa0f92e93d1581e47ccb77a04022d04cf (patch)
tree770fad80bcfa1546ab9e99373dac7e2dcaac62d3
parentbe304441d8a63df14d91c2c8ee79aa126f87d74a (diff)
downloadmeta-openembedded-80ef3c0aa0f92e93d1581e47ccb77a04022d04cf.tar.gz
Revert "maliit-framework: Clean up recipe and use gtk-immodules-cache.bbclass"
The class hasn't hit oe-core yet This reverts commit eb66e508e33ccbec8299041265eef183913a3a8c.
-rw-r--r--meta-oe/recipes-support/maliit/maliit-framework_git.bb32
1 files changed, 25 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/maliit/maliit-framework_git.bb b/meta-oe/recipes-support/maliit/maliit-framework_git.bb
index 534a3c85b6..3f50d1bc57 100644
--- a/meta-oe/recipes-support/maliit/maliit-framework_git.bb
+++ b/meta-oe/recipes-support/maliit/maliit-framework_git.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://wiki.maliit.org/Main_Page"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=5c917f6ce94ceb8d8d5e16e2fca5b9ad"
-inherit autotools qt4x11 gtk-immodules-cache
+inherit autotools qt4x11
SRC_URI = "git://gitorious.org/maliit/maliit-framework.git;branch=master \
@@ -16,8 +16,9 @@ SRCREV = "750842dec74a9b17dca91ef779c4fc5a43c4d9dc"
PV = "0.92.3+git${SRCPV}"
-PACKAGES =+ "${PN}-gtk"
-GTKIMMODULES_PACKAGES = "${PN}-gtk"
+PACKAGES =+ "\
+ ${PN}-gtk \
+ "
# Maliit needs Qt configured with -accessibility, a patch for that was already sent and will get merged in post 1.2.
RDEPENDS_${PN} = "qt4-plugin-inputmethod-imsw-multi libqtsvg4"
@@ -57,12 +58,29 @@ EXTRA_QMAKEVARS_PRE = "\
CONFIG+=local-install \
"
-EXTRA_OEMAKE += "INSTALL_ROOT=${D}"
+do_install() {
+ cd ${S} && (INSTALL_ROOT=${D} oe_runmake install)
-do_install_append() {
#Fix absolute paths
- sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${datadir}/qt4/mkspecs/features/maliit-framework.prf
- sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${datadir}/qt4/mkspecs/features/maliit-plugins.prf
+ cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ./maliit-framework.prf
+ cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ./maliit-plugins.prf
+}
+
+
+
+# Update the inputmethod modules in gtk
+pkg_postinst_${PN}-gtk() {
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+}
+
+pkg_postrm_${PN}-gtk() {
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
}
S= "${WORKDIR}/git"