aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric BENARD <eric@eukrea.com>2013-07-04 21:47:29 +0000
committerEric Bénard <eric@eukrea.com>2013-08-25 13:59:44 +0200
commit989f72c2b5d98282c8e7de04b8b961a1a320d443 (patch)
tree0bbf0d7962538e64ecbd4ece0f220dd39918d6ac
parent81bf02c1ed858b8a7ae9297b8eab7d9355d0a48c (diff)
downloadmeta-openembedded-989f72c2b5d98282c8e7de04b8b961a1a320d443.tar.gz
hexedit: new recipe
Signed-off-by: Eric Bénard <eric@eukrea.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/hexedit/hexedit/0001-don-t-strip-when-installing.patch30
-rw-r--r--meta-oe/recipes-extended/hexedit/hexedit_1.2.13.bb17
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/hexedit/hexedit/0001-don-t-strip-when-installing.patch b/meta-oe/recipes-extended/hexedit/hexedit/0001-don-t-strip-when-installing.patch
new file mode 100644
index 0000000000..a384b05cef
--- /dev/null
+++ b/meta-oe/recipes-extended/hexedit/hexedit/0001-don-t-strip-when-installing.patch
@@ -0,0 +1,30 @@
+From cc67246ca6839e5b3f6a286f10ed24c225b77a5e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Eric=20B=C3=A9nard?= <eric@eukrea.com>
+Date: Thu, 4 Jul 2013 12:34:32 +0200
+Subject: [PATCH] don't strip when installing
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Eric Bénard <eric@eukrea.com>
+
+Upstream-Status: Inappropriate [configuration]
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 159463e..735cc72 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -42,6 +42,6 @@ distclean: clean
+
+ install: $(PRODUCT)
+ $(INSTALL) -d -m 755 $(DESTDIR)$(bindir)
+- $(INSTALL) -s -m 755 $(PRODUCT) $(DESTDIR)$(bindir)
++ $(INSTALL) -m 755 $(PRODUCT) $(DESTDIR)$(bindir)
+ $(INSTALL) -d -m 755 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 644 $(PRODUCT).1 $(DESTDIR)$(mandir)/man1
+--
+1.7.10.4
+
diff --git a/meta-oe/recipes-extended/hexedit/hexedit_1.2.13.bb b/meta-oe/recipes-extended/hexedit/hexedit_1.2.13.bb
new file mode 100644
index 0000000000..d0658db58c
--- /dev/null
+++ b/meta-oe/recipes-extended/hexedit/hexedit_1.2.13.bb
@@ -0,0 +1,17 @@
+SUMMARY = "view and edit files in hexadecimal or in ASCII"
+HOMEPAGE = "http://rigaux.org/hexedit.html"
+SECTION = "console/utils"
+LICENSE = "GPLv2+"
+DEPENDS = "ncurses"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
+
+SRC_URI = "http://rigaux.org/${PN}-${PV}.src.tgz \
+ file://0001-don-t-strip-when-installing.patch "
+
+SRC_URI[md5sum] = "a5af1378d028512a9cad27a5ba3e15f9"
+SRC_URI[sha256sum] = "6a126da30a77f5c0b08038aa7a881d910e3b65d13767fb54c58c983963b88dd7"
+
+inherit autotools
+
+S = "${WORKDIR}/${PN}"