aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan McGregor <dan.mcgregor@usask.ca>2014-05-12 10:30:46 -0600
committerJoe MacDonald <joe@deserted.net>2014-06-03 21:18:51 -0400
commit4ae3822224cd78c73c3af25a137e0672278d276f (patch)
treef144cb225e2630fa9968e45347033b79d39a8f40
parent7734132dd3749e634865f0e093f6f91064d13633 (diff)
downloadmeta-openembedded-4ae3822224cd78c73c3af25a137e0672278d276f.tar.gz
netcat-openbsd: fixup patching
Do the patching in the do_patch phase instead of the compile phase. That way if the compile phase needs to be rerun patching isn't attempted a second time. Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca> Signed-off-by: Joe MacDonald <joe@deserted.net>
-rw-r--r--meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb b/meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb
index 4474e1d093..4237dc4c51 100644
--- a/meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb
+++ b/meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb
@@ -17,9 +17,18 @@ S = "${WORKDIR}/${BPN}-${PV}"
do_configure[noexec] = "1"
-do_compile() {
+netcat_do_patch() {
cd ${S}
while read line; do patch -p1 < ${WORKDIR}/debian/patches/$line; done < ${WORKDIR}/debian/patches/series
+}
+
+python do_patch() {
+ bb.build.exec_func('netcat_do_patch', d)
+ bb.build.exec_func('patch_do_patch', d)
+}
+
+do_compile() {
+ cd ${S}
pkgrel=4
oe_runmake CFLAGS="$CFLAGS -DDEBIAN_VERSION=\"\\\"${pkgrel}\\\"\""
}