aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2022-05-19 15:18:26 +0200
committerArmin Kuster <akuster808@gmail.com>2022-06-03 07:01:00 -0700
commit17da928a8de487a8c7f7c41eb8db7f8f00aa1564 (patch)
treea64e4af8c80cac1d83be20351ad8a5fec734e9d5
parent18a923d20b1885f508dfed83daaf5a8fe0d45de9 (diff)
downloadmeta-openembedded-17da928a8de487a8c7f7c41eb8db7f8f00aa1564.tar.gz
python3-speedtest-cli: fix RDEPENDS
There are packages missing in RDEPENDS needed to run speedtest-cli. Add them and use += for the assignment as we don't know what inherited classes may have added. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 3413265185dd199da0f54ef6d83abca2c8ec9b50) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb b/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb
index 06d98cbe1e..472113b059 100644
--- a/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb
+++ b/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb
@@ -7,4 +7,8 @@ SRC_URI[sha256sum] = "5e2773233cedb5fa3d8120eb7f97bcc4974b5221b254d33ff16e2f1d41
inherit pypi setuptools3
-RDEPENDS:${PN} = "${PYTHON_PN}-misc"
+RDEPENDS:${PN} += " \
+ python3-misc \
+ python3-threading \
+ python3-xml \
+"