aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-10-16 23:11:40 -0700
committerKhem Raj <raj.khem@gmail.com>2018-10-16 23:27:56 -0700
commit104a87a02e1ac810f44bb69be5befc14ee907a81 (patch)
treeef69d32c025f486f701b61efff8815412208c210
parent3e6226f85cf9076e758cbba934aa411e84c6a510 (diff)
downloadmeta-openembedded-104a87a02e1ac810f44bb69be5befc14ee907a81.tar.gz
libnet-dns-sec-perl: add recipe for 1.10
Net::DNS::SEC is installed as an extension to an existing Net::DNS installation providing packages to support DNSSEC as specified in RFC4033, RFC4034, RFC4035 and related documents. It also provides support for SIG0 which is useful for dynamic updates. Implements cryptographic signature generation and verification functions using RSA, DSA, ECDSA, and Edwards curve algorithms. The extended features are made available by replacing Net::DNS by Net::DNS::SEC in the use declaration. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-dns-sec-perl_1.10.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libnet/libnet-dns-sec-perl_1.10.bb b/meta-perl/recipes-perl/libnet/libnet-dns-sec-perl_1.10.bb
new file mode 100644
index 0000000000..3fa6294f1c
--- /dev/null
+++ b/meta-perl/recipes-perl/libnet/libnet-dns-sec-perl_1.10.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "DNSSEC extensions to Net::DNS"
+HOMEPAGE = "http://www.net-dns.org/"
+SECTION = "libs"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://README;beginline=165;endline=192;md5=6ef523fa09e8c272675839e21de16bde"
+
+SRC_URI = "https://cpan.metacpan.org/authors/id/W/WI/WILLEM/Net-DNS-SEC-${PV}.tar.gz"
+SRC_URI[md5sum] = "ffa55a9898192c9d4c623cb1357eba9b"
+SRC_URI[sha256sum] = "37a47d4def72d7338f3cc7cd807ec19bd9e2ae638ae656fa536cf0314801989e"
+
+DEPENDS += "openssl"
+
+UPSTREAM_CHECK_REGEX = "Net\-DNS\-SEC\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
+
+S = "${WORKDIR}/Net-DNS-SEC-${PV}"
+
+EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_BASELIBDIR} -lcrypto'"
+
+inherit cpan ptest-perl
+
+RDEPENDS_${PN} = " \
+ libnet-dns-perl \
+ libcrypto \
+ perl-module-dynaloader \
+ perl-module-file-find \
+ perl-module-file-spec \
+ perl-module-io-file \
+ perl-module-mime-base64 \
+ perl-module-test-more \
+"
+
+BBCLASSEXTEND = "native"