aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-05-22 23:28:35 +0000
committerKhem Raj <raj.khem@gmail.com>2019-05-23 08:26:15 -0700
commit321a62261dee657b219d4396e9cbafb7b1425e39 (patch)
treea9b0f29df93f73282ef9d7ced0954bd01ab5d69a
parent2e59ec2d28aac7384257033ea5ab68ded9d6423d (diff)
downloadmeta-openembedded-321a62261dee657b219d4396e9cbafb7b1425e39.tar.gz
ne10, libopus: add armv7ve override as well
* fix the override in packagegroup-meta-oe.bb * alllow building ne10 for armv7ve (e.g. Cortex-A15) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb3
-rw-r--r--meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb3
-rw-r--r--meta-oe/recipes-support/ne10/ne10_1.2.1.bb4
3 files changed, 7 insertions, 3 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index 89680d69a0..e34cce4eb1 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -220,7 +220,8 @@ RDEPENDS_packagegroup-meta-oe-shells ="\
NE10 = ""
NE10_aarch64 = "ne10"
-NE10_arm7 = "ne10"
+NE10_armv7a = "ne10"
+NE10_armv7ve = "ne10"
RDEPENDS_packagegroup-meta-oe-support ="\
anthy asio atop augeas avro-c bdwgc frame grail \
diff --git a/meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb b/meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb
index 50d49370ba..fb9bdc70fa 100644
--- a/meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb
+++ b/meta-oe/recipes-multimedia/libopus/libopus_1.1.3.bb
@@ -28,9 +28,10 @@ EXTRA_OECONF = " \
--enable-custom-modes \
"
-# ne10 is available only for armv7a and aarch64
+# ne10 is available only for armv7a, armv7ve and aarch64
DEPENDS_append_aarch64 = " ne10"
DEPENDS_append_armv7a = " ne10"
+DEPENDS_append_armv7ve = " ne10"
python () {
if d.getVar('TARGET_FPU') in [ 'soft' ]:
diff --git a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
index 4e8986de18..f37ccde1cb 100644
--- a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
+++ b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
@@ -15,13 +15,15 @@ PV .= "gitr+${SRCPV}"
inherit cmake
-# Incompatible with archs other than armv7 and aarch64
+# Incompatible with archs other than armv7, armv7ve and aarch64
COMPATIBLE_MACHINE = "(^$)"
COMPATIBLE_MACHINE_aarch64 = "(.*)"
COMPATIBLE_MACHINE_armv7a = "(.*)"
+COMPATIBLE_MACHINE_armv7ve = "(.*)"
NE10_TARGET_ARCH = ""
NE10_TARGET_ARCH_aarch64 = "aarch64"
NE10_TARGET_ARCH_armv7a = "armv7"
+NE10_TARGET_ARCH_armv7ve = "armv7"
EXTRA_OECMAKE = '-DGNULINUX_PLATFORM=ON -DNE10_BUILD_SHARED=ON -DNE10_LINUX_TARGET_ARCH="${NE10_TARGET_ARCH}"'