aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-13 22:40:04 -0700
committerArmin Kuster <akuster808@gmail.com>2017-09-13 17:16:28 -0700
commita7c5d85ac31235fe9e0dab5c8f2b273ba48d4f4f (patch)
treec680a0df2adf3b9e6f3439bccf7bfc21e97f6a8a
parent672c133b48f17004439eed16abea79e666495b75 (diff)
downloadmeta-openembedded-a7c5d85ac31235fe9e0dab5c8f2b273ba48d4f4f.tar.gz
imsettings: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 0cb5343932bdd4df2629d41f16a471a611fdfa2e) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch72
-rw-r--r--meta-xfce/recipes-extended/imsettings/imsettings_1.7.1.bb4
2 files changed, 75 insertions, 1 deletions
diff --git a/meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch b/meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch
new file mode 100644
index 0000000000..d77ce4d25d
--- /dev/null
+++ b/meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch
@@ -0,0 +1,72 @@
+From 7ee62ef0083844ab2fffcd106e3ee2e5f29b2a91 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 12 Jul 2017 18:53:56 -0700
+Subject: [PATCH] Rename use of stdout and stderr
+
+Since it shadow the standard definitions especially
+seen on musl where libc defines these as macros they
+cause all short of compilation errors on musl, using
+a leading underscore makes it unique
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ imsettings-daemon/imsettings-proc.c | 28 ++++++++++++++--------------
+ 1 file changed, 14 insertions(+), 14 deletions(-)
+
+diff --git a/imsettings-daemon/imsettings-proc.c b/imsettings-daemon/imsettings-proc.c
+index 915e78b..b78fcff 100644
+--- a/imsettings-daemon/imsettings-proc.c
++++ b/imsettings-daemon/imsettings-proc.c
+@@ -39,8 +39,8 @@
+ #define MAXRESTART 3
+
+ typedef struct _IMSettingsProcInfo {
+- GIOChannel *stdout;
+- GIOChannel *stderr;
++ GIOChannel *_stdout;
++ GIOChannel *_stderr;
+ GPid pid;
+ GTimeVal started_time;
+ guint id;
+@@ -368,12 +368,12 @@ _start_process(IMSettingsProc *proc,
+ &ofd, &efd,
+ error)) {
+ pinfo->pid = pid;
+- pinfo->stdout = g_io_channel_unix_new(ofd);
+- pinfo->stderr = g_io_channel_unix_new(efd);
+- g_io_channel_set_close_on_unref(pinfo->stdout, TRUE);
+- g_io_channel_set_close_on_unref(pinfo->stderr, TRUE);
+- pinfo->oid = g_io_add_watch(pinfo->stdout, G_IO_IN, _log_write_cb, proc);
+- pinfo->eid = g_io_add_watch(pinfo->stderr, G_IO_IN, _log_write_cb, proc);
++ pinfo->_stdout = g_io_channel_unix_new(ofd);
++ pinfo->_stderr = g_io_channel_unix_new(efd);
++ g_io_channel_set_close_on_unref(pinfo->_stdout, TRUE);
++ g_io_channel_set_close_on_unref(pinfo->_stderr, TRUE);
++ pinfo->oid = g_io_add_watch(pinfo->_stdout, G_IO_IN, _log_write_cb, proc);
++ pinfo->eid = g_io_add_watch(pinfo->_stderr, G_IO_IN, _log_write_cb, proc);
+ g_get_current_time(&pinfo->started_time);
+ pinfo->id = g_child_watch_add(pid, _watch_im_status_cb, proc);
+
+@@ -521,13 +521,13 @@ imsettings_proc_get_property(GObject *object,
+ static void
+ imsettings_proc_info_finalize(IMSettingsProcInfo *pinfo)
+ {
+- if (pinfo->stdout) {
+- g_io_channel_unref(pinfo->stdout);
+- pinfo->stdout = NULL;
++ if (pinfo->_stdout) {
++ g_io_channel_unref(pinfo->_stdout);
++ pinfo->_stdout = NULL;
+ }
+- if (pinfo->stderr) {
+- g_io_channel_unref(pinfo->stderr);
+- pinfo->stderr = NULL;
++ if (pinfo->_stderr) {
++ g_io_channel_unref(pinfo->_stderr);
++ pinfo->_stderr = NULL;
+ }
+ if (pinfo->oid > 0) {
+ g_source_remove(pinfo->oid);
+--
+2.13.2
+
diff --git a/meta-xfce/recipes-extended/imsettings/imsettings_1.7.1.bb b/meta-xfce/recipes-extended/imsettings/imsettings_1.7.1.bb
index e35e8b312d..c3e15db9cc 100644
--- a/meta-xfce/recipes-extended/imsettings/imsettings_1.7.1.bb
+++ b/meta-xfce/recipes-extended/imsettings/imsettings_1.7.1.bb
@@ -11,7 +11,9 @@ inherit autotools gtk-doc gobject-introspection
SRC_URI = "https://bitbucket.org/tagoh/imsettings/downloads/${BPN}-${PV}.tar.bz2 \
file://gtk-is-required-by-notify.patch \
- file://multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch"
+ file://multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch \
+ file://0001-Rename-use-of-stdout-and-stderr.patch \
+ "
SRC_URI[md5sum] = "ab439e21a7d86fa99fbc04586c755349"
SRC_URI[sha256sum] = "12c35352386057ba68d69a0b7d9a1d0d01ebbd893aafe0a094c3158c8079ac9a"