aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi-Soo An <yisooan@gmail.com>2018-11-01 22:08:38 +0900
committerArmin Kuster <akuster808@gmail.com>2018-11-15 13:18:48 -0800
commit47c0bde734d47d24ef267f836805c1e50ec32029 (patch)
tree873d83a6c95c18ee470524d3430def2d4f42bcb9
parented4472e0541dc8741dd9a7a8e6cc49e4e650eaa7 (diff)
downloadmeta-openembedded-47c0bde734d47d24ef267f836805c1e50ec32029.tar.gz
uftrace: Support x86
If TARGET_ARCH is not set to i386 for x86, build will be failed with logs such as "arch/i586: No such file or directory". In this case, TARGET_ARCH is set to i586. To succeed the build, add additional function named set_target_arch. Signed-off-by: Yi-Soo An <yisooan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb
index e377a5c9d5..ca38e6aa21 100644
--- a/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb
+++ b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb
@@ -18,7 +18,16 @@ SRC_URI = "git://github.com/namhyung/${BPN} \
S = "${WORKDIR}/git"
LDFLAGS_append_libc-musl = " -largp"
-EXTRA_UFTRACE_OECONF = "ARCH=${TARGET_ARCH} \
+
+def set_target_arch(d):
+ import re
+ arch = d.getVar('TARGET_ARCH', True)
+ if re.match(r'i.86', arch, re.I):
+ return 'i386'
+ else:
+ return arch
+
+EXTRA_UFTRACE_OECONF = "ARCH=${@set_target_arch(d)} \
with_elfutils=/use/libelf/from/sysroot"
do_configure() {
@@ -28,7 +37,7 @@ do_configure() {
FILES_SOLIBSDEV = ""
FILES_${PN} += "${libdir}/*.so"
-COMPATIBLE_HOST = "(x86_64|aarch64|arm)"
+COMPATIBLE_HOST = "(i.86|x86_64|aarch64|arm)"
# uftrace supports armv6 and above
COMPATIBLE_HOST_armv4 = 'null'