aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamien RANNOU <damien.rannou@diateam.net>2013-01-02 10:21:21 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-01-03 23:25:45 +0100
commitccda63446b88206a4bcbc91d32b6b6148c931055 (patch)
tree17c5090503d9addc3b3a75ad261631d9e12982ee
parent4d1db5cccaec59221285d97afad71a291d694d78 (diff)
downloadmeta-openembedded-ccda63446b88206a4bcbc91d32b6b6148c931055.tar.gz
HostAP-daemon patch to make it compile with libnl 3.2
Signed-off-by: Damien RANNOU <damien.rannou@diateam.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostap-daemon-1.0/defconfig2
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostap-daemon_1.0.bb1
2 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/hostapd/hostap-daemon-1.0/defconfig b/meta-oe/recipes-connectivity/hostapd/hostap-daemon-1.0/defconfig
index 1f3c6f408b..2789640170 100644
--- a/meta-oe/recipes-connectivity/hostapd/hostap-daemon-1.0/defconfig
+++ b/meta-oe/recipes-connectivity/hostapd/hostap-daemon-1.0/defconfig
@@ -24,7 +24,7 @@ CONFIG_DRIVER_PRISM54=y
# Driver interface for drivers using the nl80211 kernel interface
CONFIG_DRIVER_NL80211=y
-CONFIG_LIBNL20=y
+CONFIG_LIBNL32=y
# driver_nl80211.c requires a rather new libnl (version 1.1) which may not be
# shipped with your distribution yet. If that is the case, you need to build
# newer libnl version and point the hostapd build to use it.
diff --git a/meta-oe/recipes-connectivity/hostapd/hostap-daemon_1.0.bb b/meta-oe/recipes-connectivity/hostapd/hostap-daemon_1.0.bb
index 310e8aac05..e62531f0bb 100644
--- a/meta-oe/recipes-connectivity/hostapd/hostap-daemon_1.0.bb
+++ b/meta-oe/recipes-connectivity/hostapd/hostap-daemon_1.0.bb
@@ -26,6 +26,7 @@ do_configure() {
}
do_compile() {
+ export CFLAGS="-MMD -O2 -Wall -g -I${STAGING_INCDIR}/libnl3"
make
}