aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2014-06-11 09:03:01 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-21 10:32:30 +0200
commitee37bcbbae9bc37878513c14b8b3163c202cd3ef (patch)
tree9c950967ebe9f982c2a9650111003d24e15b403d
parentd4312063b7d8aff365698f2e978cb684d962f774 (diff)
downloadmeta-openembedded-ee37bcbbae9bc37878513c14b8b3163c202cd3ef.tar.gz
libnet: fix build issue with package upgrade
The main issue was the endianess detection. The ac override did not work. The current version has updated automake and autoconf files that address better endianess detection and it plays well with YP autotools. Build tested on all qemus arches. Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/libnet/libnet-1.1.6/fix-endianess-test.patch40
-rw-r--r--meta-oe/recipes-connectivity/libnet/libnet_1.1.6.bb23
-rw-r--r--meta-oe/recipes-connectivity/libnet/libnet_1.2-rc3.bb19
3 files changed, 19 insertions, 63 deletions
diff --git a/meta-oe/recipes-connectivity/libnet/libnet-1.1.6/fix-endianess-test.patch b/meta-oe/recipes-connectivity/libnet/libnet-1.1.6/fix-endianess-test.patch
deleted file mode 100644
index 4f9d5a4315..0000000000
--- a/meta-oe/recipes-connectivity/libnet/libnet-1.1.6/fix-endianess-test.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Use autoconf's endian check instead of the locally defined check
-so that we can determine the endianess without having to compile
-a program.
-
-Idea from http://www.security-lists.org/lists/libnet/2003/03/00001.html
-
-Also remove the old test from aclocal.m4.
-
-Rebased for libnet-1.1.6
-
-diff --git a/configure.in b/configure.in
-index e54c688..e2e768e 100644
---- a/configure.in
-+++ b/configure.in
-@@ -4,6 +4,7 @@ dnl All rights reserved.
- dnl
- dnl Process this file with autoconf to produce a configure script.
-
-+AC_PREREQ(2.52)
- AC_INIT(libnet, 1.1.6)
- AC_MSG_RESULT(beginning autoconfiguration process for libnet-${PACKAGE_VERSION} ...)
- AC_CANONICAL_SYSTEM
-@@ -38,7 +39,16 @@ dnl
- dnl And some custom things
- dnl
-
--AC_LIBNET_ENDIAN_CHECK
-+AC_C_BIGENDIAN([
-+ AC_DEFINE(LIBNET_BIG_ENDIAN)
-+ ENDIANESS="LIBNET_BIG_ENDIAN"
-+ LIBNET_CONFIG_DEFINES="$LIBNET_CONFIG_DEFINES -DLIBNET_BIG_ENDIAN"
-+],[
-+ AC_DEFINE(LIBNET_LIL_ENDIAN)
-+ ENDIANESS="LIBNET_LIL_ENDIAN"
-+ LIBNET_CONFIG_DEFINES="$LIBNET_CONFIG_DEFINES -DLIBNET_LIL_ENDIAN"
-+], AC_MSG_WARN(cannot detect endianess. try setting ac_cv_c_bigendian to yes or no))
-+
- dnl AC_LBL_LIBRARY_NET
-
- AC_SUBST(ENDIANESS)
diff --git a/meta-oe/recipes-connectivity/libnet/libnet_1.1.6.bb b/meta-oe/recipes-connectivity/libnet/libnet_1.1.6.bb
deleted file mode 100644
index 0db074b1d3..0000000000
--- a/meta-oe/recipes-connectivity/libnet/libnet_1.1.6.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-SUMMARY = "A packet dissection and creation library"
-# libnet at packetfactory.net is dead
-HOMEPAGE = "https://github.com/sam-github/libnet"
-SECTION = "libs"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://doc/COPYING;md5=fb43d5727b2d3d1238545f75ce456ec3"
-DEPENDS = "libpcap"
-# There are major API changes beween libnet v1.0 and libnet v1.1
-PROVIDES = "libnet-1.1"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/libnet-dev/${BPN}-${PV}.tar.gz \
- file://fix-endianess-test.patch"
-
-SRC_URI[md5sum] = "710296fe424a49344e5fcc0d09e53317"
-SRC_URI[sha256sum] = "d392bb5825c4b6b672fc93a0268433c86dc964e1500c279dc6d0711ea6ec467a"
-
-S = "${WORKDIR}/${BPN}-${PV}"
-
-inherit autotools binconfig
-
-do_configure_prepend() {
- rm -f aclocal.m4 Makefile.am ltmain.sh
-}
diff --git a/meta-oe/recipes-connectivity/libnet/libnet_1.2-rc3.bb b/meta-oe/recipes-connectivity/libnet/libnet_1.2-rc3.bb
new file mode 100644
index 0000000000..a558e8096c
--- /dev/null
+++ b/meta-oe/recipes-connectivity/libnet/libnet_1.2-rc3.bb
@@ -0,0 +1,19 @@
+SUMMARY = "A packet dissection and creation library"
+# libnet at packetfactory.net is dead
+HOMEPAGE = "https://github.com/sam-github/libnet"
+SECTION = "libs"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://doc/COPYING;md5=3ec839e00408b484d33b472a86b7c266"
+DEPENDS = "libpcap"
+# There are major API changes beween libnet v1.0 and libnet v1.1
+PROVIDES = "libnet-1.2rc2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libnet-dev/${BPN}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "f051e6e5bdecddb90f77c701c2ca1804"
+SRC_URI[sha256sum] = "72c380785ad44183005e654b47cc12485ee0228d7fa6b0a87109ff7614be4a63"
+
+S = "${WORKDIR}/${BPN}-${PV}"
+
+inherit autotools binconfig
+