aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-10-08 12:03:32 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-21 18:20:43 +0200
commit0f8f1973e229a0799098bc2334416fec8c608b50 (patch)
treef3a8a92512374d4388d4bb5bd9b083e7a04ce203
parenta7e7eccede498a9aeeaf040476d49fd943c8a974 (diff)
downloadmeta-openembedded-0f8f1973e229a0799098bc2334416fec8c608b50.tar.gz
jack: swap to jack2
* works out of the box without modificatins to /etc/security/limits.conf neccessary * neon support was introduced * on RaspberryPi2 buffer sizes can be set to smallest accepted value without XRUN -> reduced latency Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-multimedia/jack/jack_0.125.0rc1.bb49
-rw-r--r--meta-oe/recipes-multimedia/jack/jack_git.bb33
2 files changed, 33 insertions, 49 deletions
diff --git a/meta-oe/recipes-multimedia/jack/jack_0.125.0rc1.bb b/meta-oe/recipes-multimedia/jack/jack_0.125.0rc1.bb
deleted file mode 100644
index 07aab53540..0000000000
--- a/meta-oe/recipes-multimedia/jack/jack_0.125.0rc1.bb
+++ /dev/null
@@ -1,49 +0,0 @@
-DESCRIPTION = "JACK is a low-latency audio server. It can \
-connect a number of different applications to an audio \
-device, as well as allowing them to share audio between \
-themselves."
-SECTION = "libs/multimedia"
-
-LICENSE = "GPLv2 & LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=c030468238b2cf89925a57f2780396a7 \
- file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f \
- file://COPYING.LGPL;md5=e77fe93202736b47c07035910f47974a \
-"
-
-DEPENDS = "libsamplerate0 libsndfile1 readline db"
-
-# Seems part of our code is shared with jack2
-SRC_URI = " \
- git://github.com/jackaudio/jack1.git;name=jack \
- git://github.com/jackaudio/example-clients.git;destsuffix=git/example-clients;name=example-clients \
- git://github.com/jackaudio/tools.git;destsuffix=git/tools;name=tools \
- git://github.com/jackaudio/headers.git;destsuffix=git/jack;name=headers \
-"
-SRCREV_jack = "1ff912463e5553c515ea45a411d136e775e32613"
-SRCREV_example-clients = "7fa089095c81e81dacd2554ae3184acc7f2d58ed"
-SRCREV_tools = "02ddc6ea2f16e41326c675b1bcfcd6335390b88e"
-SRCREV_headers = "07f1ecf1ce119d861ec631cb4a6a81a1ab1e5657"
-
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-PACKAGECONFIG ??= "alsa"
-PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
-PACKAGECONFIG[portaudio] = "--enable-portaudio,--disable-portaudio,portaudio"
-
-EXTRA_OECONF = " \
- --enable-force-install \
- --enable-timestamps \
- --disable-capabilities \
- --disable-oldtrans \
- --disable-coreaudio \
- --disable-oss \
-"
-
-PACKAGES =+ "libjack jack-server jack-utils"
-
-FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
-FILES_jack-server = "${bindir}/jackd"
-FILES_jack-utils = "${bindir}/*"
-FILES_${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/* "
diff --git a/meta-oe/recipes-multimedia/jack/jack_git.bb b/meta-oe/recipes-multimedia/jack/jack_git.bb
new file mode 100644
index 0000000000..34615b4a8b
--- /dev/null
+++ b/meta-oe/recipes-multimedia/jack/jack_git.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \
+server for multi-processor machines. It is a new implementation of the \
+JACK server core features that aims in removing some limitations of \
+the JACK1 design. The activation system has been changed for a data \
+flow model and lock-free programming techniques for graph access have \
+been used to have a more dynamic and robust system."
+SECTION = "libs/multimedia"
+
+LICENSE = "GPLv2 & LGPLv2.1"
+LIC_FILES_CHKSUM = " \
+ file://common/jack/control.h;beginline=2;endline=21;md5=e6df0bf30cde8b3b825451459488195d \
+ file://common/jack/jack.h;beginline=1;endline=19;md5=6b736ed6b810592b135480a5e853392e \
+"
+
+DEPENDS = "libsamplerate0 libsndfile1 libopus readline"
+
+SRC_URI = "git://github.com/jackaudio/jack2.git"
+SRCREV = "364159f8212393442670b9c3b68b75aa39d98975"
+PV = "1.9.10+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit waf pkgconfig
+
+PACKAGECONFIG ??= "alsa"
+PACKAGECONFIG[alsa] = "--alsa=yes,alsa=no,alsa-lib"
+PACKAGECONFIG[portaudio] = "--portaudio=yes,--portaudio=no,portaudio"
+
+PACKAGES =+ "libjack jack-server jack-utils"
+
+FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
+FILES_jack-server = "${bindir}/jackd"
+FILES_jack-utils = "${bindir}/*"
+FILES_${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/* "