aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert P. J. Day <rpjday@crashcourse.ca>2016-08-18 05:32:59 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:49:29 +0200
commit107689a13348d5c1030bbdf03917ebcb143d2018 (patch)
tree7670525e7c80304113da0d4c92f3b0ae88cf5f92
parent1a2cfa6aab95cfba0f56d4922b8f87ca93cee88c (diff)
downloadmeta-openembedded-107689a13348d5c1030bbdf03917ebcb143d2018.tar.gz
meta-oe: Standardize use of "_append" versus use of "+="
Remove superfluous "+=", then manually add necessary leading space. Signed-off-by: Robert P. J. Day <rpjday@crashcourse.ca> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/krb5/krb5_1.13.2.bb4
-rw-r--r--meta-oe/recipes-connectivity/zabbix/zabbix_2.4.7.bb2
-rw-r--r--meta-oe/recipes-connectivity/zeromq/zeromq_4.1.5.bb4
-rw-r--r--meta-oe/recipes-devtools/php/php.inc2
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb2
-rw-r--r--meta-oe/recipes-support/toscoterm/toscoterm_git.bb2
6 files changed, 8 insertions, 8 deletions
diff --git a/meta-oe/recipes-connectivity/krb5/krb5_1.13.2.bb b/meta-oe/recipes-connectivity/krb5/krb5_1.13.2.bb
index 500e194d5e..3a3886bce0 100644
--- a/meta-oe/recipes-connectivity/krb5/krb5_1.13.2.bb
+++ b/meta-oe/recipes-connectivity/krb5/krb5_1.13.2.bb
@@ -57,8 +57,8 @@ CACHED_CONFIGUREVARS += "krb5_cv_attr_constructor_destructor=yes ac_cv_func_regc
ac_cv_printf_positional=yes ac_cv_file__etc_environment=yes \
ac_cv_file__etc_TIMEZONE=no"
-CFLAGS_append += "-DDESTRUCTOR_ATTR_WORKS=1 -I${STAGING_INCDIR}/et"
-LDFLAGS_append += "-lpthread"
+CFLAGS_append = " -DDESTRUCTOR_ATTR_WORKS=1 -I${STAGING_INCDIR}/et"
+LDFLAGS_append = " -lpthread"
FILES_${PN} += "${datadir}/gnats"
FILES_${PN}-doc += "${datadir}/examples"
diff --git a/meta-oe/recipes-connectivity/zabbix/zabbix_2.4.7.bb b/meta-oe/recipes-connectivity/zabbix/zabbix_2.4.7.bb
index c2c4eaefa5..03bad313c1 100644
--- a/meta-oe/recipes-connectivity/zabbix/zabbix_2.4.7.bb
+++ b/meta-oe/recipes-connectivity/zabbix/zabbix_2.4.7.bb
@@ -53,7 +53,7 @@ EXTRA_OECONF = '--enable-dependency-tracking \
--with-ssh2 \
--with-sqlite3 \
'
-CFLAGS_append += "-lldap -llber"
+CFLAGS_append = " -lldap -llber"
do_configure_prepend() {
export KERNEL_VERSION="${KERNEL_VERSION}"
diff --git a/meta-oe/recipes-connectivity/zeromq/zeromq_4.1.5.bb b/meta-oe/recipes-connectivity/zeromq/zeromq_4.1.5.bb
index 3fa572415c..34749d0b47 100644
--- a/meta-oe/recipes-connectivity/zeromq/zeromq_4.1.5.bb
+++ b/meta-oe/recipes-connectivity/zeromq/zeromq_4.1.5.bb
@@ -16,8 +16,8 @@ S = "${WORKDIR}/zeromq-${PV}"
#Uncomment to choose polling system manually. valid values are kqueue, epoll, devpoll, poll or select
#EXTRA_OECONF += "--with-poller=kqueue"
-#CFLAGS_append += "-O0"
-#CXXFLAGS_append += "-O0"
+#CFLAGS_append = " -O0"
+#CXXFLAGS_append = " -O0"
inherit autotools ptest pkgconfig
diff --git a/meta-oe/recipes-devtools/php/php.inc b/meta-oe/recipes-devtools/php/php.inc
index 988ae489e3..9d21c54fce 100644
--- a/meta-oe/recipes-devtools/php/php.inc
+++ b/meta-oe/recipes-devtools/php/php.inc
@@ -15,7 +15,7 @@ SRC_URI = "http://php.net/distributions/php-${PV}.tar.bz2 \
file://0001-acinclude-use-pkgconfig-for-libxml2-config.patch \
"
-SRC_URI_append_class-target += " \
+SRC_URI_append_class-target = " \
file://iconv.patch \
file://imap-fix-autofoo.patch \
file://pear-makefile.patch \
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
index f147714994..524f2a5431 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
@@ -37,7 +37,7 @@ EXTRA_OECONF = " \
--enable-threadsafe \
--disable-static \
"
-EXTRA_OECONF_append_armv4 += " \
+EXTRA_OECONF_append_armv4 = " \
--disable-methodjit \
"
diff --git a/meta-oe/recipes-support/toscoterm/toscoterm_git.bb b/meta-oe/recipes-support/toscoterm/toscoterm_git.bb
index 6b31fd6c45..aa031fef87 100644
--- a/meta-oe/recipes-support/toscoterm/toscoterm_git.bb
+++ b/meta-oe/recipes-support/toscoterm/toscoterm_git.bb
@@ -24,4 +24,4 @@ do_install() {
oe_runmake PREFIX="${prefix}" DESTDIR="${D}" install
}
-RDEPENDS_${PN}_append_libc-glibc += "glibc-gconv-ibm437"
+RDEPENDS_${PN}_append_libc-glibc = " glibc-gconv-ibm437"