aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLi xin <lixin.fnst@cn.fujitsu.com>2016-04-26 10:56:05 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-28 10:38:40 +0200
commit1e17ae18fa9cb4e309eebf6347fa865807494c3e (patch)
treec9186357cd26704c14711f17337554dab7c3f966
parent4d6c01395e39323a5c99e1c73694a616b73cbb52 (diff)
downloadmeta-openembedded-1e17ae18fa9cb4e309eebf6347fa865807494c3e.tar.gz
mozjs_17.0.0.bb: Fix do_srpm error
The function do_sourceclean() will lead to do_srpm failed, so use do_unpack instead. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb12
1 files changed, 3 insertions, 9 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
index cab6dd5a89..da0578914f 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
@@ -53,17 +53,11 @@ do_configure() {
}
# patch.bbclass will try to apply the patches already present and fail, so clean them out
-do_sourceclean() {
- (
- cd ${WORKDIR}/${BPN}${PV}/patches
- for i in $(cat series | awk '{print $1}') ; do
- rm -f $i
- done
- rm -f series
- )
+do_unpack() {
+ tar -xvf ${DL_DIR}/mozjs17.0.0.tar.gz -C ${WORKDIR}/
+ rm -rf ${WORKDIR}/${BPN}${PV}/patches
}
-addtask sourceclean before do_patch after do_unpack
PACKAGES =+ "lib${PN}"
FILES_lib${PN} += "${libdir}/lib*.so"