aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-09-25 21:24:12 +0800
committerKhem Raj <raj.khem@gmail.com>2018-09-25 22:24:15 -0700
commit238c1e3bee78ea18b66778569c3bf2521556be64 (patch)
treef09c664ee345b4a0d774b732950aa072774f1546
parentbec44085eff3276e06d915597032fcc9ea18c86f (diff)
downloadmeta-openembedded-238c1e3bee78ea18b66778569c3bf2521556be64.tar.gz
crda: use gcrypt as default crypt
As Makefile told us, if `USE_OPENSSL=1', only openssl10 works, even though the recipe depends libgcrypt. [Makefile snip] |ifeq ($(USE_OPENSSL),1) |CFLAGS += -DUSE_OPENSSL [snip] |else |CFLAGS += -DUSE_GCRYPT [Makefile snip] The crda dpends openssl 1.0.x which there is a build failure with openssl 1.1.x. So use gcrypt instead of openssl by default. The idea refers: https://bugs.chromium.org/p/chromium/issues/detail?id=735782 https://gitweb.gentoo.org/repo/gentoo.git/tree/net-wireless/crda/crda-3.18-r1.ebuild#n36 Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/crda/crda_3.18.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta-networking/recipes-connectivity/crda/crda_3.18.bb b/meta-networking/recipes-connectivity/crda/crda_3.18.bb
index c596dedd4a..853a52346d 100644
--- a/meta-networking/recipes-connectivity/crda/crda_3.18.bb
+++ b/meta-networking/recipes-connectivity/crda/crda_3.18.bb
@@ -4,8 +4,10 @@ SECTION = "net"
LICENSE = "copyleft-next-0.3.0"
LIC_FILES_CHKSUM = "file://copyleft-next-0.3.0;md5=8743a2c359037d4d329a31e79eabeffe"
-DEPENDS = "python-m2crypto-native python-typing-native python-native \
- libgcrypt libnl openssl10"
+DEPENDS = "python-m2crypto-native python-typing-native python-native libnl \
+ ${@oe.utils.conditional("DEFAULT_CRYPT", "gcrypt", "libgcrypt", "", d)} \
+ ${@oe.utils.conditional("DEFAULT_CRYPT", "openssl", "openssl10", "", d)} \
+ "
SRC_URI = "https://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz \
file://do-not-run-ldconfig-if-destdir-is-set.patch \
@@ -21,9 +23,12 @@ SRC_URI[sha256sum] = "43fcb9679f8b75ed87ad10944a506292def13e4afb194afa7aa921b01e
inherit python-dir pythonnative siteinfo
+# "gcrypt" or "openssl"
+DEFAULT_CRYPT ??= "gcrypt"
+
# Recursive make problem
EXTRA_OEMAKE = "MAKEFLAGS= DESTDIR=${D} LIBDIR=${libdir}/crda LDLIBREG='-Wl,-rpath,${libdir}/crda -lreg'"
-EXTRA_OEMAKE_append = " USE_OPENSSL=1"
+EXTRA_OEMAKE_append = " ${@oe.utils.conditional("DEFAULT_CRYPT", "openssl", "USE_OPENSSL=1", "", d)}"
TARGET_BITS = "${SITEINFO_BITS}"
export TARGET_BITS