aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-16 08:18:32 -0700
committerKhem Raj <raj.khem@gmail.com>2021-10-17 16:15:21 -0700
commit246b20b92c0e7e6d907385c32eb11f4350a7defa (patch)
treeddccd9e72712ea951aff20dd19a82cd3276b2c0d
parent948ee7c2e99fa275de437eee168bc63eee33cea4 (diff)
downloadmeta-openembedded-246b20b92c0e7e6d907385c32eb11f4350a7defa.tar.gz
nodejs: Upgrade to 14.18.1
License-Update: Reflect new location of gtest sources remove node-inspect from license update Acorn to v8.4.1 Use internal openssl until nodejs is fixed to work with openssl3 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_14.18.1.bb (renamed from meta-oe/recipes-devtools/nodejs/nodejs_14.17.1.bb)14
1 files changed, 5 insertions, 9 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_14.17.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_14.18.1.bb
index d468f2518e..76ff980997 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_14.17.1.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_14.18.1.bb
@@ -1,10 +1,11 @@
DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
HOMEPAGE = "http://nodejs.org"
LICENSE = "MIT & BSD & Artistic-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=a1016f9b7979cfe6fc3466a9bba60b1e"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6768abdfc4dae4fde59d6b4df96930f3"
DEPENDS = "openssl"
DEPENDS:append:class-target = " qemu-native"
+DEPENDS:append:class-native = " c-ares-native"
inherit pkgconfig python3native qemu
@@ -33,7 +34,7 @@ SRC_URI:append:toolchain-clang:x86 = " \
SRC_URI:append:toolchain-clang:powerpc64le = " \
file://0001-ppc64-Do-not-use-mminimal-toc-with-clang.patch \
"
-SRC_URI[sha256sum] = "ddf1d2d56ddf35ecd98c5ea5ddcd690b245899f289559b4330c921255f5a247f"
+SRC_URI[sha256sum] = "3fa1d71adddfab2f5e3e41874b4eddbdf92b65cade4a43922fb1e437afcf89ed"
S = "${WORKDIR}/node-v${PV}"
@@ -58,7 +59,7 @@ ARCHFLAGS:arm = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '-
GYP_DEFINES:append:mipsel = " mips_arch_variant='r1' "
ARCHFLAGS ?= ""
-PACKAGECONFIG ??= "ares brotli icu zlib"
+PACKAGECONFIG ??= "brotli icu zlib"
PACKAGECONFIG[ares] = "--shared-cares,,c-ares"
PACKAGECONFIG[brotli] = "--shared-brotli,,brotli"
@@ -87,7 +88,6 @@ python do_unpack() {
bb.build.exec_func('base_do_unpack', d)
- shutil.rmtree(d.getVar('S') + '/deps/openssl', True)
if 'ares' in d.getVar('PACKAGECONFIG'):
shutil.rmtree(d.getVar('S') + '/deps/cares', True)
if 'brotli' in d.getVar('PACKAGECONFIG'):
@@ -129,10 +129,6 @@ python do_create_v8_qemu_wrapper () {
do_create_v8_qemu_wrapper[dirs] = "${B}"
addtask create_v8_qemu_wrapper after do_configure before do_compile
-# Keep until openssl 3.x compatibility is fixed
-CXXFLAGS += "-fpermissive"
-BUILD_CXXFLAGS += "-fpermissive"
-
LDFLAGS:append:x86 = " -latomic"
# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi
@@ -140,7 +136,7 @@ do_configure () {
export LD="${CXX}"
GYP_DEFINES="${GYP_DEFINES}" export GYP_DEFINES
# $TARGET_ARCH settings don't match --dest-cpu settings
- python3 configure.py --prefix=${prefix} --cross-compiling --shared-openssl \
+ python3 configure.py --prefix=${prefix} --cross-compiling \
--without-dtrace \
--without-etw \
--dest-cpu="${@map_nodejs_arch(d.getVar('TARGET_ARCH'), d)}" \