aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2019-02-28 09:39:19 +0800
committerKhem Raj <raj.khem@gmail.com>2019-02-28 09:42:11 -0800
commit41f3f8165bde3eb4f8bcf6dddbaca0d3b760c70b (patch)
treef3ae96546cc96e2a24a273be63cfecda869ef749
parent1ccc5f9cc583434b2e3965afd3c0e96cb4b69845 (diff)
downloadmeta-openembedded-41f3f8165bde3eb4f8bcf6dddbaca0d3b760c70b.tar.gz
vim: remove xfce vim bbappend
Changing the behavior of a recipe by including a layer is not allowed by the yocto-check-layer script. INFO: ====================================================================== INFO: FAIL: test_signatures (common.CommonCheckLayer) INFO: ---------------------------------------------------------------------- INFO: Traceback (most recent call last): File "/poky/scripts/lib/checklayer/cases/common.py", line 53, in test_signatures self.fail('Adding layer %s changed signatures.\n%s' % (self.tc.layer['name'], msg)) AssertionError: Adding layer meta-xfce changed signatures. 19 signatures changed, initial differences (first hash before, second after): vim:do_install: 7f165dbd724ca0127dfb653ef0ecd8e7fb882713adedfd0e14f59d7f54cb645e -> 6e4a49063534d67f70186bf8bdb313184f42426e2c42b12b127638b586c7ffe8 bitbake-diffsigs --task vim do_install --signature 7f165dbd724ca0127dfb653ef0ecd8e7fb882713adedfd0e14f59d7f54cb645e fix by move the logic into recipe vim Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/vim/vim_8.1.0347.bb7
-rw-r--r--meta-xfce/recipes-support/vim/vim_%.bbappend1
-rw-r--r--meta-xfce/recipes-support/vim/vim_xfce.inc6
3 files changed, 7 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/vim/vim_8.1.0347.bb b/meta-oe/recipes-support/vim/vim_8.1.0347.bb
index 2a3d14a2ce..1c41caaf10 100644
--- a/meta-oe/recipes-support/vim/vim_8.1.0347.bb
+++ b/meta-oe/recipes-support/vim/vim_8.1.0347.bb
@@ -80,6 +80,13 @@ do_install() {
# we use --with-features=big as default
mv ${D}${bindir}/${BPN} ${D}${bindir}/${BPN}.${BPN}
+
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'true', 'false', d)}; then
+ # The mouse being autoenabled is just annoying in xfce4-terminal (mouse
+ # drag make vim go into visual mode and there is no right click menu),
+ # delete the block.
+ sed -i '/the mouse works just fine/,+4d' ${D}/${datadir}/${BPN}/vimrc
+ fi
}
PARALLEL_MAKEINST = ""
diff --git a/meta-xfce/recipes-support/vim/vim_%.bbappend b/meta-xfce/recipes-support/vim/vim_%.bbappend
deleted file mode 100644
index 7b449630e9..0000000000
--- a/meta-xfce/recipes-support/vim/vim_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-require ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '${BPN}_xfce.inc', '', d)}
diff --git a/meta-xfce/recipes-support/vim/vim_xfce.inc b/meta-xfce/recipes-support/vim/vim_xfce.inc
deleted file mode 100644
index 25403e6cb5..0000000000
--- a/meta-xfce/recipes-support/vim/vim_xfce.inc
+++ /dev/null
@@ -1,6 +0,0 @@
-do_install_append() {
- # The mouse being autoenabled is just annoying in xfce4-terminal (mouse
- # drag make vim go into visual mode and there is no right click menu),
- # delete the block.
- sed -i '/the mouse works just fine/,+4d' ${D}/${datadir}/${BPN}/vimrc
-}