aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric BENARD <eric@eukrea.com>2012-02-20 07:54:29 +0000
committerKhem Raj <raj.khem@gmail.com>2012-03-11 10:10:57 -0700
commit452654d05d7e7991212509ea321367c73d6575d7 (patch)
treea9735ff3b1ec0892a8cd5ffdd1591a8aafb2119d
parentb75732e3cab46d159c770d4620b37360aa3a59ac (diff)
downloadmeta-openembedded-452654d05d7e7991212509ea321367c73d6575d7.tar.gz
lzip: add new recipe
- this recipe is imported from oe-classic and upgrade to latest stable version - it was only compile tested Signed-off-by: Eric BĂ©nard <eric@eukrea.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/lzip/lzip_1.12.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/lzip/lzip_1.12.bb b/meta-oe/recipes-support/lzip/lzip_1.12.bb
new file mode 100644
index 0000000000..68f9d0d46c
--- /dev/null
+++ b/meta-oe/recipes-support/lzip/lzip_1.12.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Lzip is a lossless data compressor based on the LZMA algorithm"
+HOMEPAGE = "http://lzip.nongnu.org/lzip.html"
+SECTION = "console/utils"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
+
+SRC_URI = "http://download.savannah.gnu.org/releases/lzip/lzip-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "69a40172db5ce896b58d862c50fcd517"
+SRC_URI[sha256sum] = "eabc590d02d404dc1a1cc8e2777ed398370174b68edb22043c8ca0b209dfcd27"
+
+CONFIGUREOPTS = "\
+ '--srcdir=${S}' \
+ '--prefix=${prefix}' \
+ '--exec-prefix=${exec_prefix}' \
+ '--bindir=${bindir}' \
+ '--datadir=${datadir}' \
+ '--infodir=${infodir}' \
+ '--sysconfdir=${sysconfdir}' \
+ 'CXX=${CXX}' \
+ 'CPPFLAGS=${CPPFLAGS}' \
+ 'CXXFLAGS=${CXXFLAGS}' \
+ 'LDFLAGS=${LDFLAGS}' \
+"
+EXTRA_OEMAKE = ""
+
+B = "${S}/obj"
+do_configure () {
+ ${S}/configure ${CONFIGUREOPTS}
+}
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+BBCLASSEXTEND += "native nativesdk"