aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-03-01 18:04:43 -0800
committerArmin Kuster <akuster808@gmail.com>2018-03-16 19:15:50 -0700
commit49ecf6f65dddecaec57790de8610dc89666e31e6 (patch)
treee05b1da1a7c8b641c0b6a69b8b3208eed07e6208
parent6d2624125fb91e152e0de7c0c2b5141dee23c5c0 (diff)
downloadmeta-openembedded-49ecf6f65dddecaec57790de8610dc89666e31e6.tar.gz
python3-cryptography: Add -pthread to link flags
It builds openssl module which needs pthread_atfork() but we do not link it with libpthread, which results in runtime loading errors Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Tim Orling <ticotimo@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography_2.1.4.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_2.1.4.bb b/meta-python/recipes-devtools/python/python3-cryptography_2.1.4.bb
index f64e51d3f1..195923343b 100644
--- a/meta-python/recipes-devtools/python/python3-cryptography_2.1.4.bb
+++ b/meta-python/recipes-devtools/python/python3-cryptography_2.1.4.bb
@@ -1,6 +1,8 @@
inherit pypi setuptools3
require python-cryptography.inc
+LDSHARED += "-pthread"
+
SRC_URI += " \
file://run-ptest \
"