aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-09-27 11:04:29 -0400
committerKhem Raj <raj.khem@gmail.com>2018-09-27 08:58:18 -0700
commit5f23d82175a38542b76b5aa2a0d1db680ca68752 (patch)
tree4b9d929136ba25b29a8640d8ada5e3d71e0fb376
parenta190c2e39c1c219ab1ef34b87c3b495945b7bc32 (diff)
downloadmeta-openembedded-5f23d82175a38542b76b5aa2a0d1db680ca68752.tar.gz
libblockdev: correct PACKAGECONFIG
Since commit `6cc057d libblockdev: make various features optional' applied, it introduced issues: 1. As configure.ac told us, mpath/dm/lvm/lvm-dbus should have the same depends, runtime depends [configure.ac] |AS_IF([test "x$with_dm" != "xno" -o "x$with_lvm" != "xno" -o "x$with_lvm_dbus" != "xno" -o "x$with_mpath" != "xno"], | [LIBBLOCKDEV_PKG_CHECK_MODULES([DEVMAPPER], [devmapper >= 1.02.93])], | []) [configure.ac] 2. Remove duplicated PACKAGECONFIG tags `lvm-dbus' 3. Remove `lvm-dbus' from PACKAGECONFIG since recipe lvm2 does not support dbus 4. Align with previous configure options, we should add `mpath' Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb b/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb
index 021f641425..35f0cc0606 100644
--- a/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb
+++ b/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb
@@ -19,12 +19,12 @@ S = "${WORKDIR}/git"
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
-PACKAGECONFIG ??= "python3 lvm dm kmod parted fs escrow btrfs crypto mdraid kbd lvm-dbus"
+PACKAGECONFIG ??= "python3 lvm dm kmod parted fs escrow btrfs crypto mdraid kbd mpath"
PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2"
PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus, --without-lvm_dbus, multipath-tools, lvm2"
-PACKAGECONFIG[dm] = "--with-dm, --without-dm"
+PACKAGECONFIG[dm] = "--with-dm, --without-dm, multipath-tools, lvm2"
PACKAGECONFIG[dmraid] = "--with-dmraid, --without-dmraid"
PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd, kmod"
PACKAGECONFIG[parted] = "--with-part, --without-part, parted"
@@ -37,8 +37,7 @@ PACKAGECONFIG[btrfs] = "--with-btrfs,--without-btrfs,libbytesize btrfs-tools"
PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,cryptsetup nss volume-key"
PACKAGECONFIG[mdraid] = "--with-mdraid,--without-mdraid,libbytesize"
PACKAGECONFIG[kbd] = "--with-kbd,--without-kbd,libbytesize"
-PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus,--without-lvm_dbus"
-PACKAGECONFIG[mpath] = "--with-mpath,--without-mpath"
+PACKAGECONFIG[mpath] = "--with-mpath,--without-mpath, multipath-tools, lvm2"
export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs"