aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandru Vasiu <alexandru.vasiu@ni.com>2018-03-16 15:21:41 +0200
committerArmin Kuster <akuster808@gmail.com>2018-03-21 18:42:46 -0700
commit6015d3a4bfc77c55b80bcddcb757fb14a4555d88 (patch)
tree53db4db674a81191577564eb1bf031b1e5ec56b0
parentc09fcd618e3e6cb38748de96d8e6864086559d52 (diff)
downloadmeta-openembedded-6015d3a4bfc77c55b80bcddcb757fb14a4555d88.tar.gz
Add support for pyiface
Pyiface is a package that exposes the network interfaces of the operating system in a easy to use and transparent way. Signed-off-by: Alexandru Vasiu <alexandru.vasiu@ni.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pyiface.inc11
-rw-r--r--meta-python/recipes-devtools/python/python-pyiface_0.0.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyiface_0.0.4.bb2
3 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyiface.inc b/meta-python/recipes-devtools/python/python-pyiface.inc
new file mode 100644
index 0000000000..4d0c8dc9e2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyiface.inc
@@ -0,0 +1,11 @@
+SUMMARY = "Pyiface is a package that exposes the network interfaces of the operating system in a easy to use and transparent way"
+SECTION = "devel/python"
+HOMEPAGE = "https://pypi.python.org/pypi/pyiface/"
+LICENSE = "GPLv3+"
+
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fe06497acaf4f45999925d348c2605f9"
+
+SRC_URI[md5sum] = "edcdd71109c4259af8348006a8049c9c"
+SRC_URI[sha256sum] = "dc984de0e1bcf6871ef88b1a92d1fb75717d4f602a60caeb66136093d4a8f62e"
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-pyiface_0.0.4.bb b/meta-python/recipes-devtools/python/python-pyiface_0.0.4.bb
new file mode 100644
index 0000000000..854cb30eee
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyiface_0.0.4.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-pyiface.inc \ No newline at end of file
diff --git a/meta-python/recipes-devtools/python/python3-pyiface_0.0.4.bb b/meta-python/recipes-devtools/python/python3-pyiface_0.0.4.bb
new file mode 100644
index 0000000000..721e7b1c99
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyiface_0.0.4.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pyiface.inc