aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-11-29 15:44:35 -0500
committerArmin Kuster <akuster808@gmail.com>2017-12-11 07:58:57 -0800
commit688e28bc43504956c20599e01bb0d98186fb87f6 (patch)
tree2322b9325ac3f0aa106de970ed12ffa53ef21cbb
parentbb497805f07f192118a280bdaa9ea44a26caae76 (diff)
downloadmeta-openembedded-688e28bc43504956c20599e01bb0d98186fb87f6.tar.gz
python-asn1crypto: correct the RDEPENDS to work on a minimal python install
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-asn1crypto.inc12
-rw-r--r--meta-python/recipes-devtools/python/python3-asn1crypto_0.23.0.bb6
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-asn1crypto.inc b/meta-python/recipes-devtools/python/python-asn1crypto.inc
index 41b7342194..92c71989d8 100644
--- a/meta-python/recipes-devtools/python/python-asn1crypto.inc
+++ b/meta-python/recipes-devtools/python/python-asn1crypto.inc
@@ -10,4 +10,16 @@ SRC_URI[md5sum] = "97d54665c397b72b165768398dfdd876"
SRC_URI[sha256sum] = "0874981329cfebb366d6584c3d16e913f2a0eb026c9463efcc4aaf42a9d94d70"
inherit pypi
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-textutils \
+ ${PYTHON_PN}-subprocess \
+"
+
BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-asn1crypto_0.23.0.bb b/meta-python/recipes-devtools/python/python3-asn1crypto_0.23.0.bb
index 30f3404173..bc672158a9 100644
--- a/meta-python/recipes-devtools/python/python3-asn1crypto_0.23.0.bb
+++ b/meta-python/recipes-devtools/python/python3-asn1crypto_0.23.0.bb
@@ -1,2 +1,8 @@
inherit setuptools3
require python-asn1crypto.inc
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-enum \
+ ${PYTHON_PN}-selectors \
+ ${PYTHON_PN}-shell \
+"