aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDomarys Correa <domarys.correa@ossystems.com.br>2020-05-15 18:10:41 -0300
committerKhem Raj <raj.khem@gmail.com>2020-05-19 17:14:08 -0700
commit6cf47ddf3e5ed023548217b034f6367251e32860 (patch)
tree38926e7627c9fe299704b9e246000c1afea96751
parent7aee545a61c4f91d5e462d5b46b1b8f9a8bad1e3 (diff)
downloadmeta-openembedded-6cf47ddf3e5ed023548217b034f6367251e32860.tar.gz
python3-autobahn: Add recipe version 20.4.3
Signed-off-by: Domarys Correa <domarys.correa@ossystems.com.br> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-autobahn_20.4.3.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-autobahn_20.4.3.bb b/meta-python/recipes-devtools/python/python3-autobahn_20.4.3.bb
new file mode 100644
index 0000000000..60ef57d04d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-autobahn_20.4.3.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "WebSocket client & server library, WAMP real-time framework"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=97c0bda20ad1d845c6369c0e47a1cd98"
+
+SRC_URI[sha256sum] = "c6fe745d52ba9f9eecf791cd31f558df42aebfc4f9ee558a8f1d18c707e1ae1f"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-twisted \
+ ${PYTHON_PN}-zopeinterface \
+ ${PYTHON_PN}-py-ubjson \
+ ${PYTHON_PN}-cbor2 \
+ ${PYTHON_PN}-u-msgpack-python \
+ ${PYTHON_PN}-lz4 \
+ ${PYTHON_PN}-snappy \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-txaio \
+ ${PYTHON_PN}-six \
+"
+
+BBCLASSEXTEND = "native nativesdk"