aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-05-23 18:34:00 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2016-06-01 19:35:50 -0400
commit880c3dce369255e468cdd8dc0be6e15e913f806c (patch)
tree951b858e046a4fed3307d17f8dfeab8c42d2e087
parentd46c89ae44c811b64b117613072698601e483b32 (diff)
downloadmeta-openembedded-880c3dce369255e468cdd8dc0be6e15e913f806c.tar.gz
opensaf: update to 5.0.0
clean up to meet style guide Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb (renamed from meta-networking/recipes-daemons/opensaf/opensaf_4.7.0.bb)37
1 files changed, 17 insertions, 20 deletions
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_4.7.0.bb b/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb
index 42e883a310..f6873781d0 100644
--- a/meta-networking/recipes-daemons/opensaf/opensaf_4.7.0.bb
+++ b/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb
@@ -10,22 +10,21 @@ an informal group of supporters of the OpenSAF initiative. The OpenSAF \
Foundation was founded on January 22nd 2008 with Emerson Network Power, \
Ericsson, Nokia Siemens Networks, HP and Sun Microsystems as founding members."
HOMEPAGE = "http://www.opensaf.org"
+SECTION = "admin"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7"
-inherit autotools useradd systemd pkgconfig
+DEPENDS = "libxml2 python"
SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \
file://install-samples-from-srcdir.patch \
file://0001-plmcd-error-fix.patch \
"
-SRC_URI[md5sum] = "82dd2777a672140e22b8205f10aa55d3"
-SRC_URI[sha256sum] = "da9e138650b835728ad51d99268d3a31419b254c4cb4e87c6ec90bc45266d7d2"
-
-SECTION = "admin"
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7"
+SRC_URI[md5sum] = "94cd1a4c0406e6a45bb04c003f8690e7"
+SRC_URI[sha256sum] = "4b4188a0f3d0ed1ed0e3d77de27c45e2c96b437401de08e7df2ed9ecd54bb999"
-DEPENDS = "libxml2 python"
+inherit autotools useradd systemd pkgconfig
USERADD_PACKAGES = "${PN}"
GROUPADD_PARAM_${PN} = "-f -r opensaf"
@@ -37,22 +36,14 @@ SYSTEMD_AUTO_ENABLE = "disable"
PACKAGECONFIG[systemd] = "--enable-systemd-daemon"
PACKAGECONFIG[openhpi] = "--with-hpi-interface=B03 --enable-ais-plm,,openhpi"
-do_configure_prepend () {
- ( cd ${S}; autoreconf -f -i -s )
-}
-
EXTRA_OECONF += " --libdir=${libdir}/opensaf "
EXTRA_OEMAKE += " -Wl,-rpath,${libdir}/opensaf "
PKGLIBDIR="${libdir}/opensaf/opensaf"
-FILES_${PN} += "${localstatedir}/run"
-
-FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
-
-RDEPENDS_${PN} += "bash python"
-
-INSANE_SKIP_${PN} = "dev-so"
+do_configure_prepend () {
+ ( cd ${S}; autoreconf -f -i -s )
+}
do_install_append() {
rm -fr "${D}${localstatedir}/lock"
@@ -62,5 +53,11 @@ do_install_append() {
install -m 0644 ${B}/osaf/services/infrastructure/nid/config/opensafd.service \
${D}${systemd_unitdir}/system
install -m 0644 ${B}/contrib/plmc/config/*.service ${D}/${systemd_unitdir}/system
-
}
+
+FILES_${PN} += "${localstatedir}/run"
+FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
+
+INSANE_SKIP_${PN} = "dev-so"
+
+RDEPENDS_${PN} += "bash python"