aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBill Randle <bill.randle@gmail.com>2017-12-07 21:48:59 -0800
committerArmin Kuster <akuster808@gmail.com>2017-12-22 19:43:53 -0800
commit947c8e0cc5656bd4fb6796b68470d01c294658ff (patch)
treeb49473197594a3d696c9c7736a24ad2e8a1e6f34
parent6f3ef2e63eeefe7a44a7ea0505f53c3ee0e10744 (diff)
downloadmeta-openembedded-947c8e0cc5656bd4fb6796b68470d01c294658ff.tar.gz
python[3]-editor: new recipes
Signed-off-by: Bill Randle <bill.randle@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-editor.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-editor_1.0.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-editor_1.0.3.bb2
3 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-editor.inc b/meta-python/recipes-devtools/python/python-editor.inc
new file mode 100644
index 0000000000..30650bda41
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-editor.inc
@@ -0,0 +1,9 @@
+DESCRIPTION = "Programmatically open and editor, capture the result"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+SRC_URI[md5sum] = "0aca5f2ef176ce68e98a5b7e31372835"
+SRC_URI[sha256sum] = "a3c066acee22a1c94f63938341d4fb374e3fdd69366ed6603d7b24bed1efc565"
+
+PYPI_PACKAGE = "python-editor"
+
diff --git a/meta-python/recipes-devtools/python/python-editor_1.0.3.bb b/meta-python/recipes-devtools/python/python-editor_1.0.3.bb
new file mode 100644
index 0000000000..f7a9a8c0d5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-editor_1.0.3.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools
+require python-editor.inc
diff --git a/meta-python/recipes-devtools/python/python3-editor_1.0.3.bb b/meta-python/recipes-devtools/python/python3-editor_1.0.3.bb
new file mode 100644
index 0000000000..8ad2b869d9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-editor_1.0.3.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-editor.inc