aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-08-25 02:15:11 +0000
committerKhem Raj <raj.khem@gmail.com>2021-08-26 09:57:25 -0700
commit961755a7bd17f7347f7dd0f2de3d2400a9c36f09 (patch)
treea4a21061f68dcdaa0cec0954a174b0ad634ef565
parent5c871e1f4403c7c30cbb2924cdcb27561bb1e18e (diff)
downloadmeta-openembedded-961755a7bd17f7347f7dd0f2de3d2400a9c36f09.tar.gz
python3-django_2.2.x: only check upstream 2.2.x
AUH currently sees this recipe needing to upgrade to 3.x but we do not want that. We are intentionally pinning at the 2.2.x LTS for this recipe. References: https://www.djangoproject.com/download/ Signed-off-by: Tim Orling <timothy.t.orling@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-django_2.2.24.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-django_2.2.24.bb b/meta-python/recipes-devtools/python/python3-django_2.2.24.bb
index 2c0bcf720e..982362bdd1 100644
--- a/meta-python/recipes-devtools/python/python3-django_2.2.24.bb
+++ b/meta-python/recipes-devtools/python/python3-django_2.2.24.bb
@@ -1,4 +1,8 @@
require python-django.inc
+
+# Pin to 2.2.x LTS releases ONLY for this recipe
+UPSTREAM_CHECK_REGEX = "/${PYPI_PACKAGE}/(?P<pver>(2\.2\.\d*)+)/"
+
inherit setuptools3
SRC_URI[md5sum] = "ebf3bbb7716a7b11029e860475b9a122"