aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-08-04 04:42:26 -0400
committerJoe MacDonald <joe_macdonald@mentor.com>2016-08-05 09:13:17 -0400
commit9fb484ed579eba3ab49cb5561ad8ac86928379c7 (patch)
tree151ed025e6e61744e95a610c811e5a4cf3cbe0fe
parent85d96d1ceab43f5646fb403e29756e83ee021963 (diff)
downloadmeta-openembedded-9fb484ed579eba3ab49cb5561ad8ac86928379c7.tar.gz
proftpd: clean the host path in prxs
prxs (PRoftpd eXtenSion tool) is a perl script, in which the host path should be avoided. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb
index c9dffeeb26..b6fd4b2e11 100644
--- a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb
+++ b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb
@@ -99,6 +99,11 @@ do_install () {
-e 's,@SYSCONFDIR@,${sysconfdir},g' \
-e 's,@SBINDIR@,${sbindir},g' \
-i ${D}${systemd_unitdir}/system/*.service
+
+ sed -e 's|--sysroot=${STAGING_DIR_HOST}||g' \
+ -e 's|${STAGING_DIR_NATIVE}||g' \
+ -e 's|-fdebug-prefix-map=[^ ]*||g' \
+ -i ${D}/${bindir}/prxs
}
INITSCRIPT_NAME = "proftpd"