aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Kellermann <max.kellermann@gmail.com>2018-09-26 15:21:15 +0200
committerKhem Raj <raj.khem@gmail.com>2018-09-26 07:35:44 -0700
commita064c0d1a148a886a1810fdcf33a05f36bec4e2c (patch)
treed7b8983efd25289143236e9801b8dd690b547957
parenta7105022bfc1bd8ff1cc62440c32567328be35e6 (diff)
downloadmeta-openembedded-a064c0d1a148a886a1810fdcf33a05f36bec4e2c.tar.gz
libmms: drop obsolete "Requires:glib-2.0" from pkg-config file
Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-multimedia/libmms/libmms_0.6.4.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/libmms/libmms_0.6.4.bb b/meta-oe/recipes-multimedia/libmms/libmms_0.6.4.bb
index 831394e5c7..668afc8c16 100644
--- a/meta-oe/recipes-multimedia/libmms/libmms_0.6.4.bb
+++ b/meta-oe/recipes-multimedia/libmms/libmms_0.6.4.bb
@@ -10,3 +10,11 @@ SRC_URI[md5sum] = "d6b665b335a6360e000976e770da7691"
SRC_URI[sha256sum] = "3c05e05aebcbfcc044d9e8c2d4646cd8359be39a3f0ba8ce4e72a9094bee704f"
inherit autotools pkgconfig
+
+do_install_append() {
+ # The GLib dependency was removed in libmms 0.6.3, but the
+ # "Requires" was not removed from the pkg-config file. Since we
+ # don't have (and don't want) the RDEPENDS on GLib, we should
+ # remove the "Requires" line.
+ sed -i '/^Requires: glib-2\.0$/d' ${D}${libdir}/pkgconfig/libmms.pc
+}