aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <kergoth@gmail.com>2015-05-30 17:31:59 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2015-06-05 18:29:55 -0400
commitad4e5ab1bf32ed7a3bbd2f4f4ab26296b21f9de1 (patch)
tree30a845fd2205b58710df464cbcba81bf6cd2db17
parent15a2927106219bc11eb54bee7cd789f7f19b598e (diff)
downloadmeta-openembedded-ad4e5ab1bf32ed7a3bbd2f4f4ab26296b21f9de1.tar.gz
ntimed: add recipe to meta-networking (git version)
Ntimed is an unreleased ntpd replacement being sponsored by the Linux Foundation. Currently it only includes a work-in-progress client, but for future use this recipe emits an ntimed-client package and an ntimed meta package which will pull in client and server. Signed-off-by: Christopher Larson <kergoth@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--meta-networking/recipes-support/ntimed/ntimed/use-ldflags.patch16
-rw-r--r--meta-networking/recipes-support/ntimed/ntimed_git.bb41
2 files changed, 57 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntimed/ntimed/use-ldflags.patch b/meta-networking/recipes-support/ntimed/ntimed/use-ldflags.patch
new file mode 100644
index 0000000000..87a7778d98
--- /dev/null
+++ b/meta-networking/recipes-support/ntimed/ntimed/use-ldflags.patch
@@ -0,0 +1,16 @@
+Obey LDFLAGS.
+
+Signed-off-by: Christopher Larson <kergoth@gmail.com>
+Upstream-Status: Pending
+
+--- Ntimed.orig/configure 2015-05-30 11:57:59.927796993 -0700
++++ Ntimed/configure 2015-05-30 11:58:26.143948894 -0700
+@@ -142,7 +142,7 @@
+
+ echo
+ echo "ntimed-client: ${l}"
+- echo " \${CC} \${CFLAGS} -o ntimed-client ${l} -lm"
++ echo " \${CC} \${CFLAGS} -o ntimed-client ${l} \${LDFLAGS} -lm"
+ echo
+ echo "clean:"
+ echo " rm -f ${l} ntimed-client"
diff --git a/meta-networking/recipes-support/ntimed/ntimed_git.bb b/meta-networking/recipes-support/ntimed/ntimed_git.bb
new file mode 100644
index 0000000000..0990541784
--- /dev/null
+++ b/meta-networking/recipes-support/ntimed/ntimed_git.bb
@@ -0,0 +1,41 @@
+SUMMARY = "Network time synchronization software, NTPD replacement"
+DESCRIPTION = "This is a preview/early-access/alpha/buzzword-of-the-times \
+release of a new FOSS project written to gradually take over the world of \
+networked timekeeping."
+HOMEPAGE = "https://github.com/bsdphk/Ntimed"
+SECTION = "console/network"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://main.c;startline=2;endline=24;md5=eda11d21005319bb76cbb6f911f0f66d"
+
+SRC_URI = "git://github.com/bsdphk/Ntimed \
+ file://use-ldflags.patch"
+
+PV = "0.0+git${SRCPV}"
+SRCREV = "db0abbb4c80f2ecef6bc5d9639bca5bea28532a2"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "\
+ 'CC=${CC}' \
+ 'CFLAGS=${CFLAGS}' \
+ 'LDFLAGS=${LDFLAGS}' \
+"
+
+do_configure () {
+ sh ./configure
+}
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ install -D -m 0755 ntimed-client ${D}${sbindir}/ntimed-client
+}
+
+ALLOW_EMPTY_${PN} = "1"
+RDEPENDS_${PN} += "ntimed-client"
+
+PACKAGE_BEFORE_PN += "ntimed-client"
+FILES_ntimed-client = "${sbindir}/ntimed-client"