aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2015-11-20 11:32:39 -0600
committerJoe MacDonald <joe_macdonald@mentor.com>2015-11-30 13:18:40 -0500
commitb49d08411c75a8fec8ad591105b324a6766aa8d5 (patch)
treedd0c0bda2e8128330800589ac8230dcbbe8d91b3
parent636af36e70f2041b38080c3d6a9907bfa076cb35 (diff)
downloadmeta-openembedded-b49d08411c75a8fec8ad591105b324a6766aa8d5.tar.gz
netmap-modules: Modules may not have the same arch as userspace
Kernel modules may not have the same architecture as user space. So we tell INSANE_SKIP to skip checking the arch for the modules. This is consistent with other kernel modules and the kernel recipe. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--meta-networking/recipes-kernel/netmap/netmap-modules_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb b/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
index 23f3094afa..6e6f02ce53 100644
--- a/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
+++ b/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
@@ -39,6 +39,11 @@ python __anonymous () {
extra_oeconf_drivers = bb.utils.contains_any('NETMAP_DRIVERS', all_drivers_list, config_drivers, '--no-drivers', d)
d.appendVar("EXTRA_OECONF", extra_oeconf_drivers)
+
+ # skip the arch test for kernel modules
+ if drivers_list:
+ for driver in drivers_list:
+ d.setVar("INSANE_SKIP_kernel-module-%s-netmap" % bb.utils.prune_suffix(driver, ['.c'], d), "arch")
}
LDFLAGS := "${@'${LDFLAGS}'.replace('-Wl,-O1', '')}"