aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-01-22 01:38:02 +0100
committerKhem Raj <raj.khem@gmail.com>2019-01-22 00:52:44 -0800
commitc36ccaf595fee481a1c42cb409baf7c9d39851ff (patch)
tree0533693d9de8da6d1eec5264841a4cbb02456600
parentee77549e4c895b24abf6e2bc34737a4ba4567f79 (diff)
downloadmeta-openembedded-c36ccaf595fee481a1c42cb409baf7c9d39851ff.tar.gz
python(3)-rdflib(-native(sdk)): initial add 4.2.2
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-rdflib.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-rdflib_4.2.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-rdflib_4.2.2.bb2
3 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-rdflib.inc b/meta-python/recipes-devtools/python/python-rdflib.inc
new file mode 100644
index 0000000000..f92734aa7f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-rdflib.inc
@@ -0,0 +1,15 @@
+SUMMARY = "Character encoding aliases for legacy web content"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=68c1a3bb687bd63b8e5552f3ea249840"
+
+SRC_URI[md5sum] = "534fe35b13c5857d53fa1ac5a41eca67"
+SRC_URI[sha256sum] = "da1df14552555c5c7715d8ce71c08f404c988c58a1ecd38552d0da4fc261280d"
+
+inherit pypi
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-isodate \
+ ${PYTHON_PN}-pyparsing \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-rdflib_4.2.2.bb b/meta-python/recipes-devtools/python/python-rdflib_4.2.2.bb
new file mode 100644
index 0000000000..7ed0f5f9a0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-rdflib_4.2.2.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-rdflib.inc
diff --git a/meta-python/recipes-devtools/python/python3-rdflib_4.2.2.bb b/meta-python/recipes-devtools/python/python3-rdflib_4.2.2.bb
new file mode 100644
index 0000000000..6511df3ce1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-rdflib_4.2.2.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-rdflib.inc