aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2019-04-16 08:41:03 +0200
committerKhem Raj <raj.khem@gmail.com>2019-04-16 21:07:25 -0700
commitd4ec027ce2b83dcf43be39e326bd597e6d907af0 (patch)
tree4e29c878206c96645c7da2a0a5a589ebc3c5ca5d
parent603ae63f1005ac1f1204901304a0f3f85c6863a6 (diff)
downloadmeta-openembedded-d4ec027ce2b83dcf43be39e326bd597e6d907af0.tar.gz
paho-mqtt-c: 1.2.1 -> 1.3.0
Switch to cmake instead of manually installing everything. Paho-mqtt still adds some unnecessary files into /usr we have to delete them. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.3.0.bb (renamed from meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.2.1.bb)19
1 files changed, 6 insertions, 13 deletions
diff --git a/meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.2.1.bb b/meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.3.0.bb
index a7a9b5a6cd..79a8f43d79 100644
--- a/meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.2.1.bb
+++ b/meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.3.0.bb
@@ -13,23 +13,16 @@ LIC_FILES_CHKSUM = " \
SRC_URI = "git://github.com/eclipse/paho.mqtt.c;protocol=http"
-SRCREV = "09fe0744e02f317b907e96dd5afcc02224ddbb85"
+SRCREV = "9f715d0862a8e16099b5837c4e53a1bf6a6a0675"
DEPENDS = "openssl"
S = "${WORKDIR}/git"
-TARGET_CC_ARCH += "${LDFLAGS}"
+inherit cmake
-do_install() {
- install -d ${D}${libdir}
- oe_libinstall -C build/output -so libpaho-mqtt3a ${D}${libdir}
- oe_libinstall -C build/output -so libpaho-mqtt3as ${D}${libdir}
- oe_libinstall -C build/output -so libpaho-mqtt3c ${D}${libdir}
- oe_libinstall -C build/output -so libpaho-mqtt3cs ${D}${libdir}
- install -d ${D}${includedir}
- install -m 644 src/MQTTAsync.h ${D}${includedir}
- install -m 644 src/MQTTClient.h ${D}${includedir}
- install -m 644 src/MQTTClientPersistence.h ${D}${includedir}
+do_install_append() {
+ # paho-mqtt installes some thing that we don't want.
+ rm -rf ${D}${prefix}/samples
+ find ${D}${prefix} -maxdepth 1 -type f -delete
}
-