aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlistair Francis <alistair23@gmail.com>2019-03-28 21:49:56 -0700
committerKhem Raj <raj.khem@gmail.com>2019-03-29 10:35:27 -0700
commite02b97f1e494a6d4bb780dfd45d1317b5f28f662 (patch)
treef256ad44b48a61a87c27c5695b97e3d91ae3cb8d
parent3e46ebea6dc8f060d8ddbf75bfdd01c3a279f3b2 (diff)
downloadmeta-openembedded-e02b97f1e494a6d4bb780dfd45d1317b5f28f662.tar.gz
meta-python: Initial commit of Python3 OBDII module
Signed-off-by: Alistair Francis <alistair@alistair23.me> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-obd.inc9
-rw-r--r--meta-python/recipes-devtools/python/python3-obd_0.7.0.bb2
2 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-obd.inc b/meta-python/recipes-devtools/python/python-obd.inc
new file mode 100644
index 0000000000..f2caf64914
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-obd.inc
@@ -0,0 +1,9 @@
+DESCRIPTION = "A python module for handling realtime sensor data from OBD-II vehicle ports"
+HOMEPAGE = "https://github.com/brendan-w/python-OBD"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://README.rst;md5=2988a5e913eb105fa08011135c4157d4"
+
+SRC_URI[md5sum] = "93e04f825e13b7ebc97d06b6a6407807"
+SRC_URI[sha256sum] = "4b1bac95df2faac571ebf444778e4d736d050d8ed7049023c0fc929a520eba6d"
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python3-obd_0.7.0.bb b/meta-python/recipes-devtools/python/python3-obd_0.7.0.bb
new file mode 100644
index 0000000000..578e38d3a5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-obd_0.7.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-obd.inc