aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-10-10 17:31:05 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-21 18:20:44 +0200
commitfded4cf6a8cf1ff065af97f3283b55aeba458d28 (patch)
treea0cd377de2e76bed6c237cdf675822ed424fc056
parentdf9dac1d6ccb5087428b4be73d62faeaf5ce516e (diff)
downloadmeta-openembedded-fded4cf6a8cf1ff065af97f3283b55aeba458d28.tar.gz
opencv: fix packaging and install
The OpenCV*.cmake files and the static library should be in the opencv-dev package, not opencv-apps. There is no need to specify files for PN-dbg as they're automatically found, so remove the FILES_PN-dbg assignment. Conditionalise the installation of the example and tutorial binaries so it doesn't abort if samples are disabled. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.1.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_3.1.bb b/meta-oe/recipes-support/opencv/opencv_3.1.bb
index da1131616b..2136b0747a 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.1.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.1.bb
@@ -116,15 +116,14 @@ PACKAGES_DYNAMIC += "^libopencv-.*"
FILES_${PN} = ""
FILES_${PN}-apps = "${bindir}/* ${datadir}/OpenCV"
-FILES_${PN}-dbg += "${libdir}/.debug"
-FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig"
+FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig ${datadir}/OpenCV/*.cmake ${datadir}/OpenCV/3rdparty/lib/*.a"
FILES_${PN}-doc = "${datadir}/OpenCV/doc"
FILES_${PN}-java = "${datadir}/OpenCV/java"
FILES_${PN}-java-dbg = "${datadir}/OpenCV/java/.debug/"
FILES_${PN}-samples = "${datadir}/OpenCV/samples/"
FILES_${PN}-samples-dbg = "${datadir}/OpenCV/samples/bin/.debug"
-INSANE_SKIP_${PN}-apps = "staticdev"
+INSANE_SKIP_${PN}-dev = "staticdev"
INSANE_SKIP_${PN}-java = "libdir"
INSANE_SKIP_${PN}-java-dbg = "libdir"
@@ -144,6 +143,8 @@ do_install_append() {
rm -rf ${D}/usr/lib
fi
- install -d ${D}${datadir}/OpenCV/samples/bin/
- cp -f bin/*-tutorial-* bin/*-example-* ${D}${datadir}/OpenCV/samples/bin/
+ if ${@bb.utils.contains("PACKAGECONFIG", "samples", "true", "false", d)}; then
+ install -d ${D}${datadir}/OpenCV/samples/bin/
+ cp -f bin/*-tutorial-* bin/*-example-* ${D}${datadir}/OpenCV/samples/bin/
+ fi
}