aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-utils/xfsprogs/files
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2013-08-14 06:31:01 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-08-16 12:58:31 +0200
commiteefdbbec6c9c176ac6060ec33303b45660fd4e32 (patch)
tree445a149466547c56a7aee245d6be77033c550591 /meta-filesystems/recipes-utils/xfsprogs/files
parent6a13d57d0da17ee36749b9d98f745e10dfe26c27 (diff)
downloadmeta-openembedded-eefdbbec6c9c176ac6060ec33303b45660fd4e32.tar.gz
xfsprogs: move to meta-filesystems and upgrade
- Move xfsprogs from meta-oe to meta-filesystems - Upgrade xfsprogs to 3.1.11 [YOCTO #4178] Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-utils/xfsprogs/files')
-rw-r--r--meta-filesystems/recipes-utils/xfsprogs/files/drop-configure-check-for-aio.patch93
-rw-r--r--meta-filesystems/recipes-utils/xfsprogs/files/remove-install-as-user.patch205
2 files changed, 298 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/xfsprogs/files/drop-configure-check-for-aio.patch b/meta-filesystems/recipes-utils/xfsprogs/files/drop-configure-check-for-aio.patch
new file mode 100644
index 0000000000..760109506c
--- /dev/null
+++ b/meta-filesystems/recipes-utils/xfsprogs/files/drop-configure-check-for-aio.patch
@@ -0,0 +1,93 @@
+xfsprogs: drop configure check for aio
+
+It's unused and breaks compilation with uclibc.
+
+Upstream-Status: Pending
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ configure.ac | 6 +++---
+ m4/Makefile | 1 -
+ m4/package_aiodev.m4 | 36 ------------------------------------
+ 3 files changed, 3 insertions(+), 40 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index b968977..4e2a263 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -47,6 +47,9 @@ AC_ARG_ENABLE(lib64,
+ enable_lib64=yes)
+ AC_SUBST(enable_lib64)
+
++librt="-lrt"
++AC_SUBST(librt)
++
+ #
+ # If the user specified a libdir ending in lib64 do not append another
+ # 64 to the library names.
+@@ -92,9 +95,6 @@ AC_PACKAGE_GLOBALS(xfsprogs)
+ AC_PACKAGE_UTILITIES(xfsprogs)
+ AC_MULTILIB($enable_lib64)
+
+-AC_PACKAGE_NEED_AIO_H
+-AC_PACKAGE_NEED_LIO_LISTIO
+-
+ AC_PACKAGE_NEED_UUID_H
+ AC_PACKAGE_NEED_UUIDCOMPARE
+
+diff --git a/m4/Makefile b/m4/Makefile
+index 654a4fb..d282f0a 100644
+--- a/m4/Makefile
++++ b/m4/Makefile
+@@ -14,7 +14,6 @@ CONFIGURE = \
+
+ LSRCFILES = \
+ manual_format.m4 \
+- package_aiodev.m4 \
+ package_blkid.m4 \
+ package_globals.m4 \
+ package_libcdev.m4 \
+diff --git a/m4/package_aiodev.m4 b/m4/package_aiodev.m4
+index 490d9c8..8b13789 100644
+--- a/m4/package_aiodev.m4
++++ b/m4/package_aiodev.m4
+@@ -1,37 +1 @@
+-#
+-# Check if we have a libaio.h installed
+-#
+-AC_DEFUN([AC_PACKAGE_WANT_AIO],
+- [ AC_CHECK_HEADERS(libaio.h, [ have_aio=true ], [ have_aio=false ])
+- AC_SUBST(have_aio)
+- ])
+-
+-#
+-# Check if we have an aio.h installed
+-#
+-AC_DEFUN([AC_PACKAGE_NEED_AIO_H],
+- [ AC_CHECK_HEADERS(aio.h)
+- if test $ac_cv_header_aio_h = no; then
+- echo
+- echo 'FATAL ERROR: could not find a valid <aio.h> header.'
+- exit 1
+- fi
+- ])
+-
+-#
+-# Check if we have the lio_listio routine in either libc/librt
+-#
+-AC_DEFUN([AC_PACKAGE_NEED_LIO_LISTIO],
+- [ AC_CHECK_FUNCS(lio_listio)
+- if test $ac_cv_func_lio_listio = yes; then
+- librt=""
+- else
+- AC_CHECK_LIB(rt, lio_listio,, [
+- echo
+- echo 'FATAL ERROR: could not find a library with lio_listio.'
+- exit 1],[-lpthread])
+- librt="-lrt"
+- fi
+- AC_SUBST(librt)
+- ])
+
+--
+1.8.1.2
+
diff --git a/meta-filesystems/recipes-utils/xfsprogs/files/remove-install-as-user.patch b/meta-filesystems/recipes-utils/xfsprogs/files/remove-install-as-user.patch
new file mode 100644
index 0000000000..e761db371f
--- /dev/null
+++ b/meta-filesystems/recipes-utils/xfsprogs/files/remove-install-as-user.patch
@@ -0,0 +1,205 @@
+remove install as user
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ include/buildmacros | 2 +-
+ include/install-sh | 95 ++++++++---------------------------------------------
+ 2 files changed, 14 insertions(+), 83 deletions(-)
+
+diff --git a/include/buildmacros b/include/buildmacros
+index 7a01880..0840d55 100644
+--- a/include/buildmacros
++++ b/include/buildmacros
+@@ -30,7 +30,7 @@ OBJECTS = $(ASFILES:.s=.o) \
+ $(LFILES:.l=.o) \
+ $(YFILES:%.y=%.tab.o)
+
+-INSTALL = $(TOPDIR)/install-sh -o $(PKG_USER) -g $(PKG_GROUP)
++INSTALL = $(TOPDIR)/install-sh
+
+ IMAGES_DIR = $(TOPDIR)/all-images
+ DIST_DIR = $(TOPDIR)/dist
+diff --git a/include/install-sh b/include/install-sh
+index c952a71..b9d66f7 100755
+--- a/include/install-sh
++++ b/include/install-sh
+@@ -24,11 +24,11 @@
+ # set set | yes yes
+ #
+ _usage() {
+- echo "Usage: $prog [-o owner] [-g group] [-m mode] -d directory"
+- echo "or $prog [-D] [-o owner] [-g group] [-m mode] file directory/file"
+- echo "or $prog [-o owner] [-g group] [-m mode] file [file ...] directory"
++ echo "Usage: $prog [-m mode] -d directory"
++ echo "or $prog [-m mode] file directory/file"
++ echo "or $prog [-m mode] file [file ...] directory"
+ echo "or $prog -S file target (creates \"target\" symlink)"
+- echo "or $prog -T lt_arg [-o owner] [-g group] [-m mode] libtool.lai directory"
++ echo "or $prog -T lt_arg [-m mode] libtool.lai directory"
+ echo ""
+ echo "The \$DIST_MANIFEST and \$DIST_ROOT environment variables affect the"
+ echo "behaviour of this command - see comments in the script."
+@@ -38,32 +38,6 @@ _usage() {
+ exit 1
+ }
+
+-_chown ()
+-{
+- _st=255
+- if [ $# -eq 3 ] ; then
+- chown $1:$2 $3
+- _st=$?
+- if [ $_st -ne 0 ] ; then
+- if [ $REAL_UID != '0' ] ; then
+- if [ ! -f $DIST_ROOT/.chown.quiet ] ; then
+- echo '==============================================='
+- echo Ownership of files under ${DIST_ROOT:-/}
+- echo cannot be changed
+- echo '==============================================='
+- if [ -n "$DIST_ROOT" ] ; then
+- touch $DIST_ROOT/.chown.quiet
+- fi
+- fi
+- _st=0
+- fi
+- fi
+- fi
+-
+- return $_st
+-}
+-
+-
+ _manifest ()
+ {
+ echo $* | sed -e 's/\/\//\//g' >>${DIST_MANIFEST:-/dev/null}
+@@ -77,9 +51,6 @@ Sflag=false
+ Tflag=false
+ DIRMODE=755
+ FILEMODE=644
+-OWNER=`id -u`
+-GROUP=`id -g`
+-REAL_UID=$OWNER
+
+ # default is to install and don't append manifest
+ INSTALL=true
+@@ -94,24 +65,16 @@ MANIFEST=:
+
+ if $INSTALL
+ then
+- CP=cp; LN=ln; MKDIR=mkdir; CHMOD=chmod; CHOWN=_chown
++ CP=cp; LN=ln; MKDIR=mkdir; CHMOD=chmod;
+ else
+- CP=true; LN=true; MKDIR=true; CHMOD=true; CHOWN=true
++ CP=true; LN=true; MKDIR=true; CHMOD=true;
+ fi
+
+-[ -n "$DIST_ROOT" -a $REAL_UID -ne 0 ] && CHOWN=true
+-
+-while getopts "Dcm:d:S:o:g:T:" c $*
++while getopts "Dcm:d:S:T:" c $*
+ do
+ case $c in
+ c)
+ ;;
+- g)
+- GROUP=$OPTARG
+- ;;
+- o)
+- OWNER=$OPTARG
+- ;;
+ m)
+ DIRMODE=`expr $OPTARG`
+ FILEMODE=$DIRMODE
+@@ -146,18 +109,7 @@ then
+ # first usage
+ #
+ $MKDIR -p $dir
+- status=$?
+- if [ $status -eq 0 ]
+- then
+- $CHMOD $DIRMODE $dir
+- status=$?
+- fi
+- if [ $status -eq 0 ]
+- then
+- $CHOWN $OWNER $GROUP $dir
+- status=$?
+- fi
+- $MANIFEST d $DIRMODE $OWNER $GROUP ${dir#$DIST_ROOT}
++ $MANIFEST d $DIRMODE ${dir#$DIST_ROOT}
+ elif $Sflag
+ then
+ #
+@@ -203,7 +155,7 @@ then
+ install_name=$target/$solib
+ $CP $solib $install_name
+ status=$?
+- $MANIFEST f $FILEMODE $OWNER $GROUP $HERE/$solib ${install_name#$DIST_ROOT}
++ $MANIFEST f $FILEMODE $HERE/$solib ${install_name#$DIST_ROOT}
+ break
+ fi
+ done
+@@ -254,7 +206,7 @@ then
+ install_name=$target/$old_library
+ $CP $old_library $install_name
+ status=$?
+- $MANIFEST f $FILEMODE $OWNER $GROUP $HERE/$old_library ${install_name#$DIST_ROOT}
++ $MANIFEST f $FILEMODE $HERE/$old_library ${install_name#$DIST_ROOT}
+ ;;
+ *)
+ echo "$prog: -T $lt_install invalid"
+@@ -267,7 +219,6 @@ then
+ if [ $status -eq 0 ]
+ then
+ $CHMOD $FILEMODE $install_name
+- $CHOWN $OWNER $GROUP $install_name
+ fi
+ ;;
+ esac
+@@ -292,23 +243,10 @@ else
+ then
+ if [ -f $dir/$f ]
+ then
+- $CHMOD $FILEMODE $dir/$f
+- status=$?
+- if [ $status -eq 0 ]
+- then
+- $CHOWN $OWNER $GROUP $dir/$f
+- status=$?
+- fi
+- $MANIFEST f $FILEMODE $OWNER $GROUP $HERE/$f ${dir#$DIST_ROOT}/$f
++ $MANIFEST f $FILEMODE $HERE/$f ${dir#$DIST_ROOT}/$f
+ else
+ $CHMOD $FILEMODE $dir
+- status=$?
+- if [ $status -eq 0 ]
+- then
+- $CHOWN $OWNER $GROUP $dir
+- status=$?
+- fi
+- $MANIFEST f $FILEMODE $OWNER $GROUP $HERE/$dir ${dir#$DIST_ROOT}
++ $MANIFEST f $FILEMODE $HERE/$dir ${dir#$DIST_ROOT}
+ fi
+ fi
+ else
+@@ -334,14 +272,7 @@ else
+ status=$?
+ if [ $status -eq 0 ]
+ then
+- $CHMOD $FILEMODE $dir/$f
+- status=$?
+- if [ $status -eq 0 ]
+- then
+- $CHOWN $OWNER $GROUP $dir/$f
+- status=$?
+- fi
+- $MANIFEST f $FILEMODE $OWNER $GROUP $HERE/$f ${dir#$DIST_ROOT}/$f
++ $MANIFEST f $FILEMODE $HERE/$f ${dir#$DIST_ROOT}/$f
+ fi
+ [ $status -ne 0 ] && break
+ done
+--
+1.8.1.2
+