aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorBian Naimeng <biannm@cn.fujitsu.com>2015-06-19 11:08:08 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 14:03:54 +0200
commit3659908852b0241ecdce0a53423d7118763c1485 (patch)
tree50a6833ec99b9bfc2ce1841f7c67e0bc1a8150db /meta-filesystems
parent4a89e4c6088a3c3c3af8a228b10ee1dea9353634 (diff)
downloadmeta-openembedded-3659908852b0241ecdce0a53423d7118763c1485.tar.gz
smbnetfs: using PKG_CHECK_MODULES to found headers and libraries for smbclient
After samba was upgraded to 4.x, headers of smbclient were installed into include/samba-4.0/, so we should using PKG_CHECK_MODULES to found headers and libraries for smbclient to avoid error as below. ${WORKDIR}/git/src/samba.c | smbnetfs/git-r0/git/src/smb_conn_srv.c:12:26: fatal error: libsmbclient.h: No such file or directory #include <libsmbclient.h> | ^ | compilation terminated. | make[2]: *** [smb_conn_srv.o] Error 1 | make[2]: *** Waiting for unfinished jobs.... Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/Using-PKG_CHECK_MODULES-to-found-headers-and-libraries.patch42
-rw-r--r--meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb3
2 files changed, 44 insertions, 1 deletions
diff --git a/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/Using-PKG_CHECK_MODULES-to-found-headers-and-libraries.patch b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/Using-PKG_CHECK_MODULES-to-found-headers-and-libraries.patch
new file mode 100644
index 0000000000..f05f09f61c
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs/Using-PKG_CHECK_MODULES-to-found-headers-and-libraries.patch
@@ -0,0 +1,42 @@
+From 7a524d49b3d4459280f18942df2980603400ec52 Mon Sep 17 00:00:00 2001
+From: Bian Naimeng <biannm@cn.fujitsu.com>
+Date: Fri, 19 Jun 2015 11:54:44 +0900
+Subject: [PATCH] Using PKG_CHECK_MODULES to found headers and libraries of
+ smbclient
+
+Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
+---
+ configure.in | 5 +++++
+ src/Makefile.am | 3 +++
+ 2 files changed, 8 insertions(+)
+
+diff --git a/configure.in b/configure.in
+index ce21aef..ecd7119 100644
+--- a/configure.in
++++ b/configure.in
+@@ -125,6 +125,11 @@ AC_CHECK_LIB(smbclient, smbc_setOptionUserData,
+ )]
+ )
+
++dnl *****************************************************************
++dnl *** Check libsmbclient by pkgconfig to get cflags and ldflags ***
++dnl *****************************************************************
++PKG_CHECK_MODULES(SMBCLIENT, smbclient)
++
+ dnl ******************
+ dnl *** Final step ***
+ dnl ******************
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 41519d8..9fc97e9 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -16,3 +16,6 @@ smbnetfs_SOURCES = \
+ event.c event.h \
+ reconfigure.c reconfigure.h \
+ main.c
++
++smbnetfs_CFLAGS=${SMBCLIENT_CFLAGS}
++smbnetfs_LDFLAGS=${SMBCLIENT_LDFLAGS}
+--
+1.8.4.2
+
diff --git a/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb
index a0eddbc790..f1420fbed8 100644
--- a/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb
+++ b/meta-filesystems/recipes-filesystems/smbnetfs/smbnetfs_git.bb
@@ -17,7 +17,8 @@ PKGV = "${GITPKGVTAG}"
SRCREV = "ace1c519d45fe488b9b7e6cc77a2bcadb6c83464"
SRC_URI = "git://smbnetfs.git.sourceforge.net/gitroot/smbnetfs/smbnetfs;branch=master \
- file://configure.patch"
+ file://configure.patch \
+ file://Using-PKG_CHECK_MODULES-to-found-headers-and-libraries.patch"
PACKAGECONFIG ??= ""
PACKAGECONFIG[gnome-keyring] = "--with-gnome-keyring=yes,--with-gnome-keyring=no,libgnome-keyring"