aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/abiword/abiword
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-21 14:15:59 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-21 14:15:59 +0100
commitdea4a2dce2d247dcc9f6233e195b8497039f8547 (patch)
tree763db055c198558c0c3e068d4ce18d669c42e50a /meta-gnome/recipes-gnome/abiword/abiword
parent71b8c3b946b84ce4217d9c9dbec44611d9e1c1a3 (diff)
downloadmeta-openembedded-dea4a2dce2d247dcc9f6233e195b8497039f8547.tar.gz
abiword: update to 2.8.6
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-gnome/abiword/abiword')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword/abiword-cxx-for-ld-fix.patch12
-rwxr-xr-xmeta-gnome/recipes-gnome/abiword/abiword/autogen-common.sh28
-rwxr-xr-xmeta-gnome/recipes-gnome/abiword/abiword/cdump.pl32
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword/nodolt.patch12
4 files changed, 84 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/abiword-cxx-for-ld-fix.patch b/meta-gnome/recipes-gnome/abiword/abiword/abiword-cxx-for-ld-fix.patch
new file mode 100644
index 0000000000..e49b1e92e5
--- /dev/null
+++ b/meta-gnome/recipes-gnome/abiword/abiword/abiword-cxx-for-ld-fix.patch
@@ -0,0 +1,12 @@
+libstc++ isn't in staging anymore, so we must use g++ for linking
+
+--- /tmp/configure.ac 2008-03-31 11:39:13.130631737 +0200
++++ abiword-plugins-2.6.0/configure.ac 2008-03-31 11:39:22.754586487 +0200
+@@ -14,6 +14,7 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
++AC_LANG_CPLUSPLUS
+
+ AM_INIT_AUTOMAKE
+
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/autogen-common.sh b/meta-gnome/recipes-gnome/abiword/abiword/autogen-common.sh
new file mode 100755
index 0000000000..c1f10e1a4d
--- /dev/null
+++ b/meta-gnome/recipes-gnome/abiword/abiword/autogen-common.sh
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+# find plugins Makefile templates
+find plugins -name Makefile.am | sed 's|.am$||g' > plugin-makefiles.m4
+
+# create plugin list
+(cd plugins && find . -maxdepth 1 -type d | grep -v '^\.$' | grep -v '\./\.' | sed 's|\./||g' | xargs echo) > plugin-list.m4
+
+# create conditionals for builtin plugins
+(for plugin in `cat plugin-list.m4`; do
+ u=`echo $plugin | tr '[:lower:]' '[:upper:]'`
+ echo 'AM_CONDITIONAL(['$u'_BUILTIN], test "$enable_'$plugin'_builtin" == "yes")'
+done) > plugin-builtin.m4
+
+# create plugin configuration
+find plugins -name plugin.m4 | xargs cat > plugin-configure.m4
+#to debug if plugin configuration code misbehaves (instead of the above line):
+#rm plugin-configure.m4
+#for f in $(find plugins -name plugin.m4); do
+# echo "AC_MSG_RESULT([plugin: $f])" >> plugin-configure.m4
+# cat $f >> plugin-configure.m4
+#done
+
+# find extra m4 files provided by plugins and symlink them
+for f in ` find ./plugins -name '*.m4' | grep -v 'plugin\.m4'`; do
+ ln -sf $f
+done
+
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/cdump.pl b/meta-gnome/recipes-gnome/abiword/abiword/cdump.pl
new file mode 100755
index 0000000000..76f9c8841b
--- /dev/null
+++ b/meta-gnome/recipes-gnome/abiword/abiword/cdump.pl
@@ -0,0 +1,32 @@
+#!/usr/bin/perl
+
+# This script replace the cdump tool we used to build the ap_wp_Splash.cpp
+# Because the cdump tool has to be run as a part of building the AW package,
+# it breaks cross-compilation. A perl script seemed like a generic solution
+
+
+if ($#ARGV != 1 )
+{
+ print "Usage: $0 datafile arrayname $#ARGV $ARGV[0] $ARGV[1]\n";
+ exit(-1);
+}
+
+open FROM, "<$ARGV[0]" or die "Could not open file $ARGV[0]";
+binmode FROM;
+
+print "unsigned char $ARGV[1] [] = {\n";
+
+while ($len = read(FROM, $buf, 16))
+{
+ foreach(split(//,$buf))
+ {
+ printf("0x%02x,", ord($_));
+ }
+
+ print "\n";
+}
+
+
+printf "};\nunsigned long $ARGV[1]_sizeof = sizeof($ARGV[1]);\n";
+
+close FROM; \ No newline at end of file
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/nodolt.patch b/meta-gnome/recipes-gnome/abiword/abiword/nodolt.patch
new file mode 100644
index 0000000000..1546720804
--- /dev/null
+++ b/meta-gnome/recipes-gnome/abiword/abiword/nodolt.patch
@@ -0,0 +1,12 @@
+Index: abiword-2.8.1/configure.in
+===================================================================
+--- abiword-2.8.1.orig/configure.in
++++ abiword-2.8.1/configure.in
+@@ -132,7 +132,6 @@ AC_PROG_INSTALL
+ #AC_DISABLE_STATIC
+ AC_LIBTOOL_WIN32_DLL
+ AC_PROG_LIBTOOL
+-DOLT
+ AC_PROG_LN_S
+
+ AC_MSG_CHECKING([for platform and toolkit])