aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-05-03 12:31:05 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-03 16:12:17 +0200
commit4791fb851eb96d5785616b1793d4e6367aa52ad9 (patch)
treef1179b420d217ab364ac7bdf686b25bf76fe1b4e /meta-gnome
parent985fb27d51ecb948a195af5b27a3a3f6b5ab3f45 (diff)
downloadmeta-openembedded-4791fb851eb96d5785616b1793d4e6367aa52ad9.tar.gz
gnome-disk-utility: backport property DeviceAutomountHint
Currently we have gvfs 1.10.1 which was designed for gnome-disk-utility 3.x. We have a patched gvfs so that it works with gnome-disk-utility 2.x but that does not support the property DeviceAutomountHint because it was introduced in 3.x. Fixes warnings as: | (palimpsest:829): libgdu-WARNING **: unhandled property 'DeviceAutomountHint' Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/0001-Add-support-for-DeviceAutomountHint.patch74
-rw-r--r--meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility_2.32.0.bb3
2 files changed, 76 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/0001-Add-support-for-DeviceAutomountHint.patch b/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/0001-Add-support-for-DeviceAutomountHint.patch
new file mode 100644
index 0000000000..805e937763
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility/0001-Add-support-for-DeviceAutomountHint.patch
@@ -0,0 +1,74 @@
+From 7dde5bc75a1d96be9510ce1e98d28f9d33520919 Mon Sep 17 00:00:00 2001
+From: David Zeuthen <davidz@redhat.com>
+Date: Fri, 8 Jul 2011 11:03:52 -0400
+Subject: [PATCH] Add support for DeviceAutomountHint
+
+Based on the patch in https://bugzilla.gnome.org/show_bug.cgi?id=653184
+
+Upstream-Status: Applied [1]
+
+[1] https://mail.gnome.org/archives/commits-list/2011-July/msg03207.html
+
+Signed-off-by: David Zeuthen <davidz@redhat.com>
+---
+ src/gdu/gdu-device.c | 10 ++++++++++
+ src/gdu/gdu-device.h | 1 +
+ 2 files changed, 11 insertions(+), 0 deletions(-)
+
+diff --git a/src/gdu/gdu-device.c b/src/gdu/gdu-device.c
+index 6a5afad..4be39cf 100644
+--- a/src/gdu/gdu-device.c
++++ b/src/gdu/gdu-device.c
+@@ -82,6 +82,7 @@ typedef struct
+ gboolean device_presentation_nopolicy;
+ char *device_presentation_name;
+ char *device_presentation_icon_name;
++ char *device_automount_hint;
+ guint64 device_size;
+ guint64 device_block_size;
+
+@@ -279,6 +280,8 @@ collect_props (const char *key,
+ props->device_presentation_name = g_strdup (g_value_get_string (value));
+ else if (strcmp (key, "DevicePresentationIconName") == 0)
+ props->device_presentation_icon_name = g_strdup (g_value_get_string (value));
++ else if (strcmp (key, "DeviceAutomountHint") == 0)
++ props->device_automount_hint = g_strdup (g_value_get_string (value));
+ else if (strcmp (key, "DeviceSize") == 0)
+ props->device_size = g_value_get_uint64 (value);
+ else if (strcmp (key, "DeviceBlockSize") == 0)
+@@ -549,6 +552,7 @@ device_properties_free (DeviceProperties *props)
+ g_strfreev (props->device_mount_paths);
+ g_free (props->device_presentation_name);
+ g_free (props->device_presentation_icon_name);
++ g_free (props->device_automount_hint);
+ g_free (props->job_id);
+ g_free (props->id_usage);
+ g_free (props->id_type);
+@@ -1294,6 +1298,12 @@ gdu_device_drive_get_media_compatibility (GduDevice *device)
+ }
+
+ const char *
++gdu_device_get_automount_hint (GduDevice *device)
++{
++ return device->priv->props->device_automount_hint;
++}
++
++const char *
+ gdu_device_drive_get_media (GduDevice *device)
+ {
+ return device->priv->props->drive_media;
+diff --git a/src/gdu/gdu-device.h b/src/gdu/gdu-device.h
+index 4c1302b..8cfd7a9 100644
+--- a/src/gdu/gdu-device.h
++++ b/src/gdu/gdu-device.h
+@@ -143,6 +143,7 @@ const char *gdu_device_drive_get_wwn (GduDevice *device);
+ const char *gdu_device_drive_get_connection_interface (GduDevice *device);
+ guint64 gdu_device_drive_get_connection_speed (GduDevice *device);
+ char **gdu_device_drive_get_media_compatibility (GduDevice *device);
++const gchar *gdu_device_get_automount_hint(GduDevice *device);
+ const char *gdu_device_drive_get_media (GduDevice *device);
+ gboolean gdu_device_drive_get_is_media_ejectable (GduDevice *device);
+ gboolean gdu_device_drive_get_requires_eject (GduDevice *device);
+--
+1.7.6.5
+
diff --git a/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility_2.32.0.bb b/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility_2.32.0.bb
index a0fd9bdba7..ac4a759aad 100644
--- a/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility_2.32.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility_2.32.0.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=e9115d11797a5e6b746b4e9b90194564"
DEPENDS = "glib-2.0 gtk+ libnotify libunique udisks avahi-ui virtual/libx11 libatasmart nautilus"
-PR = "r3"
+PR = "r4"
inherit gnome
SRC_URI[archive.md5sum] = "f0366c8baebca0404d190b2d78f3582d"
@@ -15,6 +15,7 @@ SRC_URI += "\
file://disable-scrollkeeper.patch \
file://fix-dbus-interfaces.patch \
file://sysrooted-pkg-config.patch \
+ file://0001-Add-support-for-DeviceAutomountHint.patch \
"
EXTRA_OECONF += "--disable-scrollkeeper"