aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorTrevor Woerner <trevor.woerner@linaro.org>2014-04-09 22:12:51 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-20 10:40:28 +0200
commit6f1b5c555d7a28da9ba85812d8239a9378cb64b1 (patch)
tree54080a0831b361436a90124e068b61fc003fb679 /meta-gnome
parent0aaf18723d7280b62af3e66106859bc5c51a185a (diff)
downloadmeta-openembedded-6f1b5c555d7a28da9ba85812d8239a9378cb64b1.tar.gz
abiword: force build order
There is a race condition whereby "libgoffice.la" must be built (and exist) before the rest of the code in "src" is built. Signed-off-by: Trevor Woerner <trevor.woerner@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb b/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb
index 69d62efa16..073622a723 100644
--- a/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb
+++ b/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb
@@ -50,6 +50,14 @@ do_configure() {
autotools_do_configure
}
+do_compile() {
+ cd ${S}/goffice-bits2
+ make goffice-paths.h
+ make libgoffice.la
+ cd ${S}
+ oe_runmake
+}
+
PACKAGES += " ${PN}-clipart ${PN}-strings ${PN}-systemprofiles ${PN}-templates "
FILES_${PN} += " \