aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-05-21 15:41:57 +0200
committerAndreas Müller <schnitzeltony@googlemail.com>2014-10-01 10:11:35 +0200
commit94c8dec97061907266406f8163c7335261798f8e (patch)
tree0e8a5be17258ecb0389d5b9e3919379e927fe578 /meta-gnome
parent0d01e1b72333f49c29d1a27ad844c4cd9f90341c (diff)
downloadmeta-openembedded-94c8dec97061907266406f8163c7335261798f8e.tar.gz
faenza-icon-theme: initial add 1.3
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/faenza-icon-theme/faenza-icon-theme_1.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/faenza-icon-theme/faenza-icon-theme_1.3.bb b/meta-gnome/recipes-gnome/faenza-icon-theme/faenza-icon-theme_1.3.bb
new file mode 100644
index 0000000000..dbaae649e8
--- /dev/null
+++ b/meta-gnome/recipes-gnome/faenza-icon-theme/faenza-icon-theme_1.3.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "An icon theme for Gnome"
+SECTION = "x11/wm"
+LICENSE = "GPLv3"
+HOMEPAGE = "http://code.google.com/p/faenza-icon-theme/"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+inherit allarch gtk-icon-cache
+
+S = "${WORKDIR}"
+
+SRC_URI = "http://faenza-icon-theme.googlecode.com/files/${PN}_${PV}.zip"
+SRC_URI[md5sum] = "e9bd6106d13017ce06d24b586259ae9c"
+SRC_URI[sha256sum] = "d4486fda0413f8a81a87e0dd2329f50f2a8a7cb4147b48cf147f0160add8174a"
+
+do_install() {
+ install -d ${D}${datadir}/icons
+ for theme in `find -name 'Faenza*.tar.gz'`; do
+ tar -xf ${theme} -C ${D}${datadir}/icons
+ done
+ tar -xf emesene-faenza-theme.tar.gz -C ${D}${datadir}
+ mv -f ${D}${datadir}/emesene/themes ${D}${datadir}/themes
+ rm -rf ${D}${datadir}/emesene
+}
+
+FILES_${PN} += "${datadir}/icons ${datadir}/themes"