aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-05-31 14:47:08 +0800
committerKhem Raj <raj.khem@gmail.com>2021-06-01 07:49:06 -0700
commit66d7739e3bb4e4002bd7b1ea643e6b884b42b238 (patch)
tree2df9bd8cecbb9798b4c685db65d5ab3d727f7ec7 /meta-gnome
parent9cd1523504ad5f6235e51af8865e741f44c7eff7 (diff)
downloadmeta-openembedded-66d7739e3bb4e4002bd7b1ea643e6b884b42b238.tar.gz
libstemmer: upgrade 2.0.0 -> 2.1.0
0002-snowball-stemwords-do-link-with-LDFLAGS-set-by-build.patch Removed since this is included in 2.1.0 Refresh the following patch: 0001-Build-so-lib.patch -License-Update: Add the following Copyright Copyright (c) 2013, Yoshiki Shibukawa Copyright (c) 2006,2007,2009,2010,2011,2014-2019, Olly Betts Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-support/libstemmer/libstemmer/0001-Build-so-lib.patch6
-rw-r--r--meta-gnome/recipes-support/libstemmer/libstemmer/0002-snowball-stemwords-do-link-with-LDFLAGS-set-by-build.patch46
-rw-r--r--meta-gnome/recipes-support/libstemmer/libstemmer_git.bb7
3 files changed, 6 insertions, 53 deletions
diff --git a/meta-gnome/recipes-support/libstemmer/libstemmer/0001-Build-so-lib.patch b/meta-gnome/recipes-support/libstemmer/libstemmer/0001-Build-so-lib.patch
index 73ebeb4847..37c5c3dc02 100644
--- a/meta-gnome/recipes-support/libstemmer/libstemmer/0001-Build-so-lib.patch
+++ b/meta-gnome/recipes-support/libstemmer/libstemmer/0001-Build-so-lib.patch
@@ -23,7 +23,7 @@ diff --git a/GNUmakefile b/GNUmakefile
index cbd6ff7..a85230b 100644
--- a/GNUmakefile
+++ b/GNUmakefile
-@@ -142,10 +142,10 @@ C_OTHER_OBJECTS = $(C_OTHER_SOURCES:.c=.o)
+@@ -162,10 +162,10 @@ C_OTHER_OBJECTS = $(C_OTHER_SOURCES:.c=.o)
JAVA_CLASSES = $(JAVA_SOURCES:.java=.class)
JAVA_RUNTIME_CLASSES=$(JAVARUNTIME_SOURCES:.java=.class)
@@ -36,7 +36,7 @@ index cbd6ff7..a85230b 100644
clean:
rm -f $(COMPILER_OBJECTS) $(RUNTIME_OBJECTS) \
-@@ -192,6 +192,9 @@ libstemmer/libstemmer.o: libstemmer/modules.h $(C_LIB_HEADERS)
+@@ -212,6 +212,9 @@ libstemmer/libstemmer.o: libstemmer/modules.h $(C_LIB_HEADERS)
libstemmer.o: libstemmer/libstemmer.o $(RUNTIME_OBJECTS) $(C_LIB_OBJECTS)
$(AR) -cru $@ $^
@@ -44,7 +44,7 @@ index cbd6ff7..a85230b 100644
+ $(CC) $(CFLAGS) -shared $(LDFLAGS) -Wl,-soname,libstemmer.so.0,-version-script,libstemmer/symbol.map -o $@.0.0.0 $^
+
stemwords: $(STEMWORDS_OBJECTS) libstemmer.o
- $(CC) $(CFLAGS) -o $@ $^
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
diff --git a/libstemmer/symbol.map b/libstemmer/symbol.map
new file mode 100644
diff --git a/meta-gnome/recipes-support/libstemmer/libstemmer/0002-snowball-stemwords-do-link-with-LDFLAGS-set-by-build.patch b/meta-gnome/recipes-support/libstemmer/libstemmer/0002-snowball-stemwords-do-link-with-LDFLAGS-set-by-build.patch
deleted file mode 100644
index 69c1d670e7..0000000000
--- a/meta-gnome/recipes-support/libstemmer/libstemmer/0002-snowball-stemwords-do-link-with-LDFLAGS-set-by-build.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 23eacfbcc10c777ce47283a5285455ec83c8aa41 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
-Date: Sun, 6 Oct 2019 13:05:08 +0200
-Subject: [PATCH] snowball/stemwords: do link with LDFLAGS set by build
- environment
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Some (cross-)build systems as OpeneEmbedded are picky (for certain reasons) if
-their LDFLAGS are ignored.
-
-Upstream-Status: Submitted [1]
-
-[1] https://github.com/snowballstem/snowball/pull/120
-
-Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
----
- GNUmakefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/GNUmakefile b/GNUmakefile
-index 76f6ae9..47c6077 100644
---- a/GNUmakefile
-+++ b/GNUmakefile
-@@ -179,7 +179,7 @@ clean:
- -rmdir $(js_output_dir)
-
- snowball: $(COMPILER_OBJECTS)
-- $(CC) $(CFLAGS) -o $@ $^
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
-
- $(COMPILER_OBJECTS): $(COMPILER_HEADERS)
-
-@@ -204,7 +204,7 @@ libstemmer.so: libstemmer/libstemmer.o $(RUNTIME_OBJECTS) $(C_LIB_OBJECTS)
- $(CC) $(CFLAGS) -shared $(LDFLAGS) -Wl,-soname,libstemmer.so.0,-version-script,libstemmer/symbol.map -o $@.0.0.0 $^
-
- stemwords: $(STEMWORDS_OBJECTS) libstemmer.o
-- $(CC) $(CFLAGS) -o $@ $^
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
-
- csharp_stemwords: $(CSHARP_STEMWORDS_SOURCES) $(CSHARP_RUNTIME_SOURCES) $(CSHARP_SOURCES)
- $(MCS) -unsafe -target:exe -out:$@ $(CSHARP_STEMWORDS_SOURCES) $(CSHARP_RUNTIME_SOURCES) $(CSHARP_SOURCES)
---
-2.21.0
-
diff --git a/meta-gnome/recipes-support/libstemmer/libstemmer_git.bb b/meta-gnome/recipes-support/libstemmer/libstemmer_git.bb
index 96dd880b6a..c1a06c0d0d 100644
--- a/meta-gnome/recipes-support/libstemmer/libstemmer_git.bb
+++ b/meta-gnome/recipes-support/libstemmer/libstemmer_git.bb
@@ -1,18 +1,17 @@
SUMMARY = "Snowball compiler and stemming algorithms"
HOMEPAGE = "https://snowballstem.org/"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://COPYING;md5=2750797da77c1d784e7626b3f7d7ff3e"
+LIC_FILES_CHKSUM = "file://COPYING;md5=19139aaf3c8c8fa1ca6edd59c072fb9f"
DEPENDS_class-target = "${BPN}-native"
SRC_URI = "\
git://github.com/snowballstem/snowball.git \
file://0001-Build-so-lib.patch \
- file://0002-snowball-stemwords-do-link-with-LDFLAGS-set-by-build.patch \
"
-SRCREV = "c70ed64f9d41c1032fba4e962b054f8e9d489a74"
+SRCREV = "4764395431c8f2a0b4fe18b816ab1fc966a45837"
S = "${WORKDIR}/git"
-PV = "2.0.0"
+PV = "2.1.0"
LIBVER = "0.0.0"
inherit lib_package