aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-09-08 17:42:59 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-23 15:37:16 +0200
commit3fc7af6b12210ff9e39ea61d93a903c6050bcc49 (patch)
treed0a67f9534d89231d8853f3395e98464d7953118 /meta-gnome
parentce03697c02ddd214745c51ce7ed35a9a9bdd3fc6 (diff)
downloadmeta-openembedded-3fc7af6b12210ff9e39ea61d93a903c6050bcc49.tar.gz
gnome-settings-daemon: fix build for libnotify > 0.7.x
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-settings-daemon/files/0001-Require-libnotify-0.6.0.patch81
-rw-r--r--meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_2.32.1.bb5
2 files changed, 85 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-settings-daemon/files/0001-Require-libnotify-0.6.0.patch b/meta-gnome/recipes-gnome/gnome-settings-daemon/files/0001-Require-libnotify-0.6.0.patch
new file mode 100644
index 0000000000..6dd33f3517
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-settings-daemon/files/0001-Require-libnotify-0.6.0.patch
@@ -0,0 +1,81 @@
+From e1ab570b0dce479ba235e5542ea07d1b5bafc4c9 Mon Sep 17 00:00:00 2001
+From: William Jon McCann <jmccann@redhat.com>
+Date: Mon, 11 Oct 2010 23:35:45 -0400
+Subject: [PATCH] Require libnotify 0.6.0
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+
+Upstream-Status: Backport
+
+---
+ configure.ac | 2 +-
+ plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c | 8 ++------
+ plugins/xrandr/gsd-xrandr-manager.c | 13 +++----------
+ 3 files changed, 6 insertions(+), 17 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 8a90053..8624b2a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -54,7 +54,7 @@ GTK_REQUIRED_VERSION=2.91.0
+ GCONF_REQUIRED_VERSION=2.6.1
+ GIO_REQUIRED_VERSION=2.17.3
+ GNOME_DESKTOP_REQUIRED_VERSION=2.29.92
+-LIBNOTIFY_REQUIRED_VERSION=0.4.3
++LIBNOTIFY_REQUIRED_VERSION=0.6.1
+
+ EXTRA_COMPILE_WARNINGS(yes)
+
+diff --git a/plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c b/plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c
+index 9ca820a..f5964b9 100644
+--- a/plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c
++++ b/plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c
+@@ -608,9 +608,7 @@ ax_slowkeys_warning_post_bubble (GsdA11yKeyboardManager *manager,
+ gsd_a11y_keyboard_manager_ensure_status_icon (manager);
+ manager->priv->notification = notify_notification_new (title,
+ message,
+- "preferences-desktop-accessibility",
+- NULL);
+- notify_notification_attach_to_status_icon (manager->priv->notification, manager->priv->status_icon);
++ "preferences-desktop-accessibility");
+ notify_notification_set_timeout (manager->priv->notification, NOTIFICATION_TIMEOUT * 1000);
+
+ notify_notification_add_action (manager->priv->notification,
+@@ -747,9 +745,7 @@ ax_stickykeys_warning_post_bubble (GsdA11yKeyboardManager *manager,
+ gsd_a11y_keyboard_manager_ensure_status_icon (manager);
+ manager->priv->notification = notify_notification_new (title,
+ message,
+- "preferences-desktop-accessibility",
+- NULL);
+- notify_notification_attach_to_status_icon (manager->priv->notification, manager->priv->status_icon);
++ "preferences-desktop-accessibility");
+ notify_notification_set_timeout (manager->priv->notification, NOTIFICATION_TIMEOUT * 1000);
+
+ notify_notification_add_action (manager->priv->notification,
+diff --git a/plugins/xrandr/gsd-xrandr-manager.c b/plugins/xrandr/gsd-xrandr-manager.c
+index 02536a3..ef57d5b 100644
+--- a/plugins/xrandr/gsd-xrandr-manager.c
++++ b/plugins/xrandr/gsd-xrandr-manager.c
+@@ -1084,16 +1084,9 @@ error_message (GsdXrandrManager *mgr, const char *primary_text, GError *error_to
+
+ g_assert (error_to_display == NULL || secondary_text == NULL);
+
+- if (priv->status_icon)
+- notification = notify_notification_new_with_status_icon (primary_text,
+- error_to_display ? error_to_display->message : secondary_text,
+- GSD_XRANDR_ICON_NAME,
+- priv->status_icon);
+- else
+- notification = notify_notification_new (primary_text,
+- error_to_display ? error_to_display->message : secondary_text,
+- GSD_XRANDR_ICON_NAME,
+- NULL);
++ notification = notify_notification_new (primary_text,
++ error_to_display ? error_to_display->message : secondary_text,
++ GSD_XRANDR_ICON_NAME);
+
+ notify_notification_show (notification, NULL); /* NULL-GError */
+ #else
+--
+2.1.0
+
diff --git a/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_2.32.1.bb
index e06c5f91c3..f8ece37219 100644
--- a/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_2.32.1.bb
+++ b/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_2.32.1.bb
@@ -8,7 +8,10 @@ DEPENDS = "intltool libxxf86misc libsndfile1 libxtst glib-2.0 polkit gtk+ gconf
inherit gnome
-SRC_URI = "git://git.gnome.org/gnome-settings-daemon;branch=gnome-2-32"
+SRC_URI = " \
+ git://git.gnome.org/gnome-settings-daemon;branch=gnome-2-32 \
+ file://0001-Require-libnotify-0.6.0.patch \
+"
SRCREV = "0160f6725cfb872e017f3958f108792c3b882872"
S = "${WORKDIR}/git"