aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-10-20 17:59:34 +0200
committerKhem Raj <raj.khem@gmail.com>2019-10-21 04:44:10 -0700
commit9294da37f820a898c556c4db2b3b855703bef5fe (patch)
treea285e07526a4d7cf7fa7f5d4ff0c868e676ee8af /meta-gnome
parenta7464eaa69a7ee4734001aab2e232102e7135772 (diff)
downloadmeta-openembedded-9294da37f820a898c556c4db2b3b855703bef5fe.tar.gz
dconf: Fix build with meson 0.52
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Slightly adjusted patch sent to mailing list [1] [1] http://lists.openembedded.org/pipermail/openembedded-core/2019-October/288108.html Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/dconf/dconf/fix-meson-0.52.patch25
-rw-r--r--meta-gnome/recipes-gnome/dconf/dconf_0.34.0.bb2
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/dconf/dconf/fix-meson-0.52.patch b/meta-gnome/recipes-gnome/dconf/dconf/fix-meson-0.52.patch
new file mode 100644
index 0000000000..485c46509c
--- /dev/null
+++ b/meta-gnome/recipes-gnome/dconf/dconf/fix-meson-0.52.patch
@@ -0,0 +1,25 @@
+With meson 0.52 the build fails due to duplicate symbols. There is a fix
+to meson but the dconf build also needs tweaking.
+
+https://gitlab.gnome.org/GNOME/dconf/issues/59
+https://github.com/mesonbuild/meson/pull/5936
+
+Despite the comments there about this being incorrect, libdconf is unchanged
+between 0.51 and 0.52 and this patch.
+
+Upstream-Status: Pending [under discussion, see above links]
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+
+Index: dconf-0.34.0/client/meson.build
+===================================================================
+--- dconf-0.34.0.orig/client/meson.build
++++ dconf-0.34.0/client/meson.build
+@@ -28,7 +28,7 @@ libdconf_client = static_library(
+
+ libdconf_client_dep = declare_dependency(
+ dependencies: gio_dep,
+- link_whole: libdconf_client,
++ link_with: libdconf_client,
+ )
+
+ libdconf = shared_library(
diff --git a/meta-gnome/recipes-gnome/dconf/dconf_0.34.0.bb b/meta-gnome/recipes-gnome/dconf/dconf_0.34.0.bb
index a1996a1a37..ef549432e8 100644
--- a/meta-gnome/recipes-gnome/dconf/dconf_0.34.0.bb
+++ b/meta-gnome/recipes-gnome/dconf/dconf_0.34.0.bb
@@ -12,6 +12,8 @@ GNOMEBASEBUILDCLASS = "meson"
inherit gnomebase bash-completion vala
+SRC_URI += "file://fix-meson-0.52.patch"
+
# I/O error : Attempt to load network entity http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
EXTRA_OEMESON = "-Dman=false"