aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-02-22 19:01:44 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-14 12:15:24 +0100
commitb784dffd106e9ea87897b7b59afd1f3cd32a13ba (patch)
tree8e0d51df5a19e56c3f364964b34ea16b5be7f90c /meta-gnome
parent4dad5a8a04bcf0d55d1795eb2f8879c39432785a (diff)
downloadmeta-openembedded-b784dffd106e9ea87897b7b59afd1f3cd32a13ba.tar.gz
evolution-data-server: fix gobject introspection
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb b/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
index 426076fb21..a5664b0856 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
@@ -28,7 +28,7 @@ SRC_URI = " \
S = "${WORKDIR}/git"
-inherit autotools gtk-doc pkgconfig gettext
+inherit autotools gtk-doc pkgconfig gettext gobject-introspection
# -ldb needs this on some platforms
LDFLAGS += "-lpthread"
@@ -42,6 +42,10 @@ do_configure_append () {
cp ${WORKDIR}/iconv-detect.h ${S}
}
+do_compile_prepend() {
+ export GIR_EXTRA_LIBS_PATH="${B}/camel/.libs:${B}/libedataserver/.libs"
+}
+
EXTRA_OECONF = "--without-openldap \
--with-libdb=${STAGING_DIR_HOST}${prefix} \
--disable-nntp --disable-goa --disable-weather"