aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.25.bb
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2012-02-21 00:21:53 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-02-22 09:40:24 +0100
commit25c2e973e02ecc2a0aff4ccea8c53c42519ff5e3 (patch)
treee30b37fbe42d536c34b55bb6364e5f1ccde80108 /meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.25.bb
parent59c8231315753b91a4ded9a615a3c855ef5e77de (diff)
downloadmeta-openembedded-25c2e973e02ecc2a0aff4ccea8c53c42519ff5e3.tar.gz
meta-initramfs: import klibc recipe and bbclass from meta-oe
Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.25.bb')
-rw-r--r--meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.25.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.25.bb b/meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.25.bb
new file mode 100644
index 0000000000..922c8d84f2
--- /dev/null
+++ b/meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.25.bb
@@ -0,0 +1,33 @@
+PR = "${INC_PR}.0"
+
+require klibc.inc
+require klibc-checksums_${PV}.inc
+
+export KLCC_INST = "${STAGING_DIR_TARGET}/lib/klibc"
+
+SRC_URI += "file://klcc_prefix.patch \
+ file://use-env-for-perl.patch"
+
+DEPENDS = "klibc"
+
+FILESPATH =. "${FILE_DIRNAME}/klibc-${PV}:"
+
+# ${TARGET_PREFIX}klcc is just a
+# perl wrapper around gcc-cross
+# so give it the same arch and path
+PACKAGE_ARCH = "${TUNE_PKGARCH}"
+
+inherit cross
+
+do_configure () {
+ :
+}
+
+do_compile() {
+ oe_runmake klcc
+}
+
+do_install() {
+ install -d ${D}${base_bindir}
+ install -m 0755 klcc/klcc ${D}${base_bindir}/${TARGET_PREFIX}klcc
+}